Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Forum der DL-QRP-AG für QRP und Selbstbau im Amateurfunk. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 2. Juni 2012, 18:09

Signalgenerator

Hallo,

ich habe direkt noch eine Frage zu einem QRPproject-Bausatz, nämlich zum HF-Prüfgenerator/Signalgenerator Version II. Ich habe ihn ohne Schwierigkeiten aufbauen können, und grundsätzlich funktioniert er auch, aber die Signalform am Ausgang weicht relativ stark von einer reinen Sinuskurve ab. Siehe das beigefügte Bild (dabei habe ich einen 3,5795 MHz-Quarz verwendet). Der qualitative Signalverlauf ist im Wesentlichen auch unabhängig von der eingestellten Signalamplitude (Poti/Trimmer).

Meine Frage ist nun: Ist eine derarige Abweichung der Kurvenform von der "reinen" Sinuskurve normal, oder mache ich etwas falsch?

Mit herzlichem Dank und vielen Grüßen,

Sebastian
»DD1AH« hat folgendes Bild angehängt:
  • MAP003.gif

2

Sonntag, 3. Juni 2012, 21:36

Hallo Sebastian,

da noch keiner Deine Frage beantwortet hat, versuche ich es einmal.
Ich habe den Oszillator nicht, daher "Ferndiagnose" per Schaltbild, siehe unten.

1) versuche einmal mit dem Scope zu messen ob bereits an dem Mittelanzapf von P1 hinter dem 220pF C das Signal so ist ?
Wenn ja, ist wahrscheinlich die Kopplung der beiden Rückkopplung-Cs 220p, 150p an der Basis von T1 BF199 zu stark, spiele mal mit kleineren als 150pf Werten herum, ggf. auch beide Werte ändern

2) wenn nein, dann liegt es eher am Fet-Follower
hier wäre dann die Überprüfung aller Komponenten (Wert des Bauteils richtig ?) notwendig.

Sollten beide Maßnahmen nicht greifen, wären DC-Spannungswerte (gemessen mit >10MOhm Messgerät) eingetragen in das Schaltbild für eine weitere Diagnose sinnvoll!

73, eric1
PS: es sollte aus so einer Schaltung ein schöner sauberer Sinus erzeugbar sein !
Ein Foto Deines Aufbaus wäre auch hilfreich zur Diagnose!
»eric1« hat folgendes Bild angehängt:
  • QRP-Generator.jpg

3

Sonntag, 3. Juni 2012, 22:08

Hallo Sebastian

Keine Sorge.Mein Signal sieht genauso aus.

vy 72 Christoph,dl3akf
Chris/dl3akf

4

Montag, 4. Juni 2012, 22:33

Hallo eric1,

vielen Dank für Deine hilfreiche Antwort.

In der Tat ist es so, dass schon am 220pF-C hinter der Mittelanzapfung von P1 bzw. am Gate des BF244 das Signal auf die gleiche Art wie am Ausgang verzerrt ist. Und zwar ist bemerkenswerterweise die Amplitude an dieser Stelle mit ca. 2,2 Vss sehr viel größer als am Ausgang mit ca. 600 mVss (bei überbrücktem Dämpfungsglied und mit P2 auf Maximum).

Die Verkleinerung der Rückkopplungskondensatoren 220 bzw. 150 pF bringt nicht viel, die Signalform ändert sich dadurch nicht wesentlich. (Es sei denn, man geht mit einem der beiden Kondensatoren unter ca. 70 pF, dann bekommt man sehr chaotische Schwingungen mit starken Oberwellen.)

Da die Amplitude am Ausgang der ersten Stufe so auffällig groß war, bin ich auch noch auf den Gedanken gekommen, selbige zu verringern, indem ich den Rückkopplungswiderstand von 15k (wischen B und C des BF199) auf ca. 80k zu erhöhen (das ist ungefähr der maximale Wert, bevor die Schwingungen vollständig abreißen). Damit habe ich dann - bei stark verringerter Amplitude - tatsächlich annähernd eine Sinuskurve erhalten.

Fotos vom Aufbau des Bausatzes (Vorder-/Rückseite) hängen an. Für die Experimente habe ich aber den ersten Teil der Schaltung nochmal separat aufgebaut (und dabei die beiden Kondensatoren durch je einen festen C plus einen Trimmkondensator, sowie den 15k-Widerstand durch ein Trimmpoti ersetzt).

Fällt Dir dazu noch etwas ein? Habe ich recht mit meinem Eindruck, dass die 2,2 Vss hinter dem BF199 zu viel des Guten sind? Gibt es noch andere sinnvolle schaltungstechnische Methoden, die Amplitude zu verringern, um dadurch die Linearität zu erhöhen?

Viele Grüße,

Sebastian
»DD1AH« hat folgende Bilder angehängt:
  • vorderseite.jpg
  • rueckseite.jpg

5

Dienstag, 5. Juni 2012, 13:01

Hallo Sebastian,

Zunächst habe ich noch eine Dimensionierungsvorschrift für die Cs des Coclpits-Oszillators gefunden (siehe Anlage)

Ich habe um Deine Fragen zu beantworten die kleine Schaltung auch einmal rasch quick & dirty aufgebaut und erhalte ähnliche verzerrte Signale wie Du.
Wahrscheinlich hängen die Verzerrungen auch mit der sehr niedrigen Spannung von 3V zusammen.


Zitat

Fällt Dir dazu noch etwas ein? Habe ich recht mit meinem Eindruck, dass die 2,2 Vss hinter dem BF199 zu viel des Guten sind? Gibt es noch andere sinnvolle schaltungstechnische Methoden, die Amplitude zu verringern, um dadurch die Linearität zu erhöhen?

Hmm, so etwas Bahnbrechendes habe ich auch noch nicht gefunden ?(
Ja, der Transistor ist eindeutig übersteuert, der Eindruck von Dir ist richtig.
Die Schaltung ist ja so eingestellt, dass sie bei 3V Versorgungsspannung, ca. 1.5V an der Basis hat und dann noch ca. 0.7V am Emitter. Damit fließen in dem 1K P2 so 700uA DC.
Eine gewisse Gegenkopplung bildet wohl der 4.7Ohm R und natürlich sollte man an dem Teilerverhältnis der Cs (220pF, 150pF) spielen.
Ich habe hier auch beobachtet, dass die Verzerrungen von der Quarzfrequenz (und auch wahrscheinlich von dessen Güte) abhängen.
Man findet in der Literatur auch dass der 220pF nicht an dem Punkt wie hier angekoppelt ist, sondern direkt am Quarz und dass dann zwischen Quarz und Basis noch einmal ein kleines C geschaltet ist, mit dem man die Ankopplung des Quarzes verringern kann.

Eine wechselstrommäßige Verringerung von P1 durch parallel schalten von 1K in Serie mit einem C , brachte auch noch keinen Erfolg.

Zitat

Fotos vom Aufbau des Bausatzes (Vorder-/Rückseite) hängen an.
Danke, soweit habe ich nichts Böses entdecken können, einzig die Masselötungen sehen so aus, als wenn Du nicht genug Wärme in die riesigen wärmeabziehenden Cu-Flächen bringen konntest, evtl. hier die Löttemperatur und Zeit etwas erhöhen bis das Zinn wirklich schön verläuft.

73, eric1
»eric1« hat folgendes Bild angehängt:
  • Oszillator.jpg

6

Dienstag, 5. Juni 2012, 14:50

Was auf dem Oszillogramm verzerrt aussieht, macht sich im Frequenzspektrum wahrscheinlich noch ganz passabel.
Wenn man einen schöne Sinuskurve "sehen" will, kann man ja einfach einen Tiefpass dahinter schalten, der die Harmonischen unterdrückt.

73, Günter

7

Dienstag, 5. Juni 2012, 16:14

Hallo Sebastian,
ich habe mir die Schaltung und das Oszillogramm angesehen und tippe auf den 100nF Kondensator, der bei der hohen Frequenz mit dem Umladen in dieser Schaltung diese Welle erzeugt. 4,7nF sollte da mal eingebaut werden.

Außerdem fehlt vor der Z-Diode 2,7V ein Vorwiderstand, was bewirkt, das erst einmal die Batterie auf 2,7V entladen wird. Ich würde die Z-Diode entfernen.
Vy 72/73 de Gerhard

8

Dienstag, 5. Juni 2012, 16:19

... und tippe auf den 100nF Kondensator, der bei der hohen Frequenz mit dem Umladen in dieser Schaltung diese Welle erzeugt.

wohl eher nicht, dann vorher wurde geschrieben:

In der Tat ist es so, dass schon am 220pF-C hinter der Mittelanzapfung von P1 bzw. am Gate des BF244 das Signal auf die gleiche Art wie am Ausgang verzerrt ist.

Es wäre mir auch vollkommen neu, wenn ein Koppel-Kondensator (so er denn den Namen verdient) nichtlineare Verzerrungen eines hochfrequenten Wechselstromsignals hervorrufen würde. Ein großer Kondensator bedeutet lediglich ein kleines Xc.

73, Günter

9

Dienstag, 5. Juni 2012, 16:41

Du meine Güte, worum geht es hier bloß?

Es handelt sich um einen einfachen Prüfoszillator, nicht um einen Mutteroszillator, aus dem später. Er soll mit Quarzen über den ganzen KW Bereich ein Messsignal erzeigen können, mit dem dann ein Selbstbau RX abgeglichen werden kann. Mehr nicht.

Der Vorwiderstand ist schon seit Ewigkeiten zugefügt. Die niedrige Betriebsspannung ist notwendig, damit die Amplitude nicht zu groß wird so dass man auch ein kleines Signal erhalten kann ohne einen aufwändigen Abschwächer zu benutzen.

Da es ein einfacher Bausatz sein sollte, der trotzdem den kompletten Bereich abdeckt, waren Kompromisse nötig. Die Beule im Sinus stört bei der Verwendung als einfacher Signalgenerator überhaupt nicht. Der Oberwellenabstand ist nicht viel schlechter als bei sehr teuren, durchstimmbaren Signalgeneratoren.
73/2 de Peter, DL2FI
Proud member of Second Class Operators Club SOC and Flying Pig Zapper #OOO (Certificated Kit Destroyer)

10

Dienstag, 5. Juni 2012, 16:44

Sebastian,

ich habe kürzlich sehr viel mit VXCOs experimentiert und Dein Signal entspricht (leider) dem Signal eines kapazitiven Colpittsoszillators, ohne Resonanzschwingkreis, auch bei anderer Betriebsspannung. Eric hat den richtigen Richer. Schau Dir mal das Signal an der Basis von T1 an, evtl. den Tastkopf mit einem 1pF Kondensator anschließen, um die Rückkopplung/Frequenz nicht zu sehr zu verstimmen. Hier sollte ein relativ sauberer Sinus anliegen, da der Quartz einen Schwingkreis hoher Güte darstellt. Alternativ beidseitig der Induktivität in Serie zum Quarz. T1 kontrolliert ohne Übersteuerung arbeiten zu lassen ist schwierig, wenn gar unmöglich. Der FET hat einen sehr hochohmigen Eingang. Daher sollte es möglich sein den 15k R an der Basis von T1 durch ein Poti zu ersetzen und über einen kleineren Kondensator (probier mal 10 pF) das Signal an den FET zu führen. Der Arbeitspunkt des FET muss dann sauber eingestellt werden, um keine Übersteuerung und damit Oberwellen zu haben.

Die Alternative ist, die Pufferstufe (FET) im Source/Drainpfad mit einem Parallelschwingkreis auszustatten, um die Oberwellen von T1 wieder auszufiltern. Dies passt dann aber nur für die eine Frequenz. Bei Quartzwechsel muss umdimensioniert werden. Selbst mit einer Festinduktivität erhälts Du aber allemal ein besseres Signal als auf Deinem Foto. Da dürften etliche Oberwellenanteile enthalten sein.

Alles Ferndiagnose...

73, Michael, DG5MK

PS: Der 15k Rückkopplungswiderstand ist keiner. Er liegt über dem 100 Ohm R an der Betriebsspannung und bildet zusammen mit dem anderen 15k R die Basisvorspannung von T1. Sonst würde dieser nicht Schwingen.

11

Dienstag, 5. Juni 2012, 22:39

Hallo Sebastian,

ich bin sehr in Eile, weil wir nachher los fahren.
Aber es wäre ja gelacht wenn die Leute in einem "Selbstbau- und Selbstlernforum" sich nicht zu helfen wüssten, wie sie ggf. ein Lösung erzeugen, die ursprünglich anders gedacht war :rolleyes:

Beim Herumspielen kam ich auf die Idee den R=4.7R stark zu vergrößern, um die Gegenkopplung zu erhöhen, dazu muss der Verbindungspunkt der beiden Cs (220p, 150p) verschoben werden, aus Faulheit habe ich den versuchsweise an den Abgriffspunkt des Potis gehängt, das ist natürlich keine Lösung sondern nur ein quick & dirty Versuch. Er zeigt aber, dass man sehr wohl einen recht reinen Sinus erzeugen kann, der Zusatz- R wird dann allerdings recht hoch einige 10...100OHm)
Wenn man das weiter optimiert, bin ich überzeugt dass man auch über den gesamten Frequenzbereich eine gangbare Lösung erzielen kann.
Hier nun die Änderung und Messungen bei mir

73, eric1
PS: die vermeintlichen Verzerrungen in meiner Scope-Darstellung ist der schräge Winkel bei der Foto-Aufnahme !
ich habe nur die BF199-Stufe aufgebaut
»eric1« hat folgende Bilder angehängt:
  • unvollständige schnelle Änderung.jpg
  • 6_5MHzvor Komp.JPG
  • 6_5MHz_nach komp.JPG
  • Aufbau_quick-and-dirty.jpg

12

Dienstag, 5. Juni 2012, 23:30

Hallo Eric,

vielen herzlichen Dank für Deine ausführliche und engagierte Hilfe und Deinen Rat. Dein Vorschlag, den Gegenkopplungs-R von 4,7Ohm auf einige hundert Ohm (bei mir ca. 300 Ohm) zu erhöhen, bringt mir tatsächlich eine nahezu perfekte Sinuswelle ein, wie ich sie mir gewünscht habe. :) Siehe Bild.

Über die anderen gemachten Vorschläge muss ich noch nachdenken. Ich bin von morgen bis Sonntag auf Reisen, und komme deshalb leider erst danach dazu, darüber nachzudenken und mich wieder zu melden. Aber ich habe die Sache nicht vergessen. :-)

Mit herzlichen Grüßen,

Sebastian
»DD1AH« hat folgendes Bild angehängt:
  • MAP006.gif

13

Dienstag, 5. Juni 2012, 23:42

Du meine Güte, worum geht es hier bloß?

Es handelt sich um einen einfachen Prüfoszillator, nicht um einen Mutteroszillator, aus dem später. Er soll mit Quarzen über den ganzen KW Bereich ein Messsignal erzeigen können, mit dem dann ein Selbstbau RX abgeglichen werden kann. Mehr nicht.

Der Vorwiderstand ist schon seit Ewigkeiten zugefügt. Die niedrige Betriebsspannung ist notwendig, damit die Amplitude nicht zu groß wird so dass man auch ein kleines Signal erhalten kann ohne einen aufwändigen Abschwächer zu benutzen.

Da es ein einfacher Bausatz sein sollte, der trotzdem den kompletten Bereich abdeckt, waren Kompromisse nötig. Die Beule im Sinus stört bei der Verwendung als einfacher Signalgenerator überhaupt nicht. Der Oberwellenabstand ist nicht viel schlechter als bei sehr teuren, durchstimmbaren Signalgeneratoren.

Hallo Peter,

sorry für den Aufruhr. :) Mir ist schon klar, dass es nur ein einfacher Signalgenerator ist. Nur bin ich noch Neueinsteiger in der HF-Technik, und weiß daher noch nicht immer genau, was ich an Verhalten von derartigen Schaltungen erwarten kann. Deshalb, und auch um die Schaltung besser zu verstehen, habe ich meine Fragen gestellt. Es war nicht als Kritik am Bausatz gedacht. Ich hoffe, das ist ok. :)

Viele Grüße,

Sebastian

P.S. Ich bin von morgen bis Sonntag auf Reisen, und kann erst nach meiner Rückkehr wieder antworten.