Mein QMX zickt rum ...

  • Hallo zusammen,

    ich habe Anfang des Jahres einen QMX-Bausatz gekauft und auch erfolgreich aufgebaut, denn die ersten QSOs über FT-8 konnte ich bereits damit führen.
    Ich nutze hierfür WSJT-X in der Version 2.6.1 auf einem Rechner mit Ubuntu 22.04 LTS. Leider "zickt" der QMX regelmäßig rum und aufgrund mangelnder Informationen über die Ursache, ist die Problemlösung immer recht zeitaufwändig, zum Teil auch unmöglich.

    Ich liste jetzt einfach mal alle Problme auf, in der Hoffnung, dass diese bekannt sind - ebenso wie die Lösung ;)

    - Starte ich WSJT-X mit angeschlossenem QMX, funktioniert zwar häufig direkt die CAT-Steuerung, es werden jedoch nicht immer Daten empfangen

    --> Ziehe ich den USB-Stecker und verbinde den QMX erneut (auch ein- und ausschalten ist möglich) wird irgendwann empfangen und es kann auch decodiert werden, allerdings funktioniert dann häufig die CAT-Steuerung nicht mehr.
    --> Startet man den QMX häufig genug neu, steckt den USB-Stecker oder startet auch mal den Rechner neu, funktioniert irgendwann empfangen, decodieren und senden
    --> relativ neu ist das Problem, dass er gar nicht mehr senden mag - egal ob an einer Antenne oder am Dummyload. Das Senden funktioniert dann noch nicht mal mehr über die Diagnosefunktion per serieller Konsole. Ich habe auch schon mehrfach einen reset der Firmware durchgeführt aber ohne Erfolg. Irgendwann funktioniert es dann wieder ohne, dass ich nachvollziehen kann warum.


    - Ein weiteres Probem ist, dass ich ausschließlich auf dem 10m Band einen zu geringen Eingangspegel habe (Anzeige wird zwischendurch orange/rot). Allerdings kann ich bei mir im Ubuntu-System keine Änderung vornehmen und auf den anderen Bändern passt es ja auch.

    Anbei ein Screenshot, wenn ich erfolglos über die serielle Konsole senden möchte (Power 0W, kein SWR) sowie zwei Screenshots der seriellen Konsole, die mir mal bei Verbindung angezeigt wurden, die ich bisher aber nicht mehr "finden" konnte ... aber vielleicht hilft das ja bei der Fehlersuche?!

    Vielen Dank!

  • Moin Thorsten,

    erst mal ist ein Firmware Upgrade ungebracht, denn das ist bei Problemen immer der erste Schritt.

    Für eine Lösung des Problems ist es evtl. sinnvoller in der Gruppe von QRP-Labs bei groups.io zu bemühen.

    Mit genügend Linux-Kenntnissen könntest Du die geschilderten Probleme mit den Logfiles analysieren, in dem Du untersuchst, was der Kernel zu den Verbindungen ins Log schreibt, gegebenenfalls mit erweiterten Debug Infos. Grundsätzlich gibt es dazu Einträge, wenn ein Device Probleme macht.

    73, Tom

    Ich bin dann mal weg ...

  • Hallo Thorsten,

    die Hauptursache für Nicht-Empfang ist, dass die Zeit nicht mehr synchron ist, habe ich mit dem von mir genutzen Rechner auch immer wieder. Zu anfang ging es auch bei mir, weil zufällig gerade die Internet-Time-Synch gelaufen war.

    Lösung: Regelmäßig explizit die Synchronisation der Zeit des Rechners mit einem Internet-Zeit-Server auslösen (Einstellungen Datum&Zeit Internet-Zeit-Sync...)

    Mach' das mal, dann schauen wir weiter ;)

    vy73

    Thilo - dl7ame

  • Anbei ein Screenshot, wenn ich erfolglos über die serielle Konsole senden möchte (Power 0W, kein SWR)

    Hallo Thorsten,

    ich kenne zwei Zustände, die hier passen (könnten). Im Menü unter CW Keyer kann Practice mode aktiviert sein oder der SWR-Schutz (Protection) hat zugeschlagen. In beiden Fällen gibt es auf dem Display einen Hinweis. Rechts von der Frequenzanzeige in der ersten Zeile erscheint der Buchstabe "P" bzw. "S".

    Es trifft hier wohl nicht zu, kann aber gelegentlich hilreich sein: Auf dem Display gibt es bei digi mode eine Anzeige für das Aktivieren des Tx und das tatsächliche Senden des Tons. Genauers steht im Operating manual unter "Transmit status indication during QMX digital transmissions".

    auf einem Rechner mit Ubuntu

    Zum Betrieb unter Linux gibt es im Operating manual den Abschnitt "Linux special note". (RTFM ;) )

    Wenn das nicht hilft könnte eine Frage hier helfen. Da gab es schon gelegentlich solche Themen.

    Ein weiteres Probem ist, dass ich ausschließlich auf dem 10m Band einen zu geringen Eingangspegel habe

    Im QMX gibt es für jedes Band einen Parameter "Audio Gain". (RTFM Abschnitt "8.5 Band configuration")

    73, Ludwig

  • Moin,

    Lösung: Regelmäßig explizit die Synchronisation der Zeit des Rechners mit einem Internet-Zeit-Server auslösen (Einstellungen Datum&Zeit Internet-Zeit-Sync...)

    Regelmässig macht das System das von selbst, wenn es aktiviert ist. Möchte man kürzere Abstände, dann konfiguriert man timesyncd vollständig, d.h. auch die anderen Zeilen auskommentieren und unter ntp eine Liste von funktionierenden ntp Servern eintragen. Man sollte aber die Pollintervalle nicht zu klein machen, manche ntp Server mögen das verständlicherweise nicht. timesyncd fängt aber immer mit den minimalen Werten an, bis die Zeit synchronisiert ist und erhöht dann die Pollintervalle bis zum max. Wert, weil so ungenau sind die Timer heute nicht mehr. Grundsätzlich ist es natürlich richtig, dass die Zeit bei diesen Sendearten schon stimmen muss, aber das muss man wirklich nicht händisch machen. Unter Windows kann man das Pollintervall in der Registry anpassen, dazu sind auch keine extra Tools notwendig.

    73, Tom

    Ich bin dann mal weg ...

  • Uhrzeit des Systems checken => time.is

    Wird nichts empfangen/gesendet => Soundkarte checken. Es kann vorkommen, daß die Einstellungen weg sind. K.A. warum.

    Wenn Du die Soundkarte Einstellst, dann gleich die vom QMX nehmen, nicht über pulse gehen. Die erkent man in der Auswahlbox. Evtl. das Programm erst nach dem Anstecken starten.

    Selbiges, wenn Cat mal nicht will. Wenn man mehrere USB Geräte hat, selbigen Typs, dann geht es da mit ttyUSBx ttyASMCx schon mal durcheinander.

    Besser ist es, wenn du den eindeutigen Pfad nimmst "/dev/serial/by-id/" und dort natürlich die passende Schnittstelle anfügen.

    Die ist dann meistens fix.

    PS: Wenn Du die Lautstärke am Eingang nicht ändern kannst, pavucontrol => Eingabegeräte, dann musst du statt der QMX Soundkarte pulse wählen, dann sollte es gehen.

    73, Jens

    Telegrafie - die einzige Digitalbetriebsart die Analog besser ist.

    Edited once, last by DD5NT: nachtrag (May 2, 2024 at 6:50 AM).

  • Hallo zusammen,

    erst mal ist ein Firmware Upgrade ungebracht, denn das ist bei Problemen immer der erste Schritt.

    Das habe ich natürlich vorher gemacht - gestern Abend habe ich sogar das Update vom 1. Mai aufgespielt!

    Mit genügend Linux-Kenntnissen könntest Du die geschilderten Probleme mit den Logfiles analysieren, in dem Du untersuchst, was der Kernel zu den Verbindungen ins Log schreibt, gegebenenfalls mit erweiterten Debug Infos.

    Grundsätzlich eine gute Idee, was ich aber noch vergessen habe zu erwähnen ist, dass es nicht mal immer eine Ausgabe über die Kopfhörer gibt. Hier muss ich dann zwischen Digi und CW sowie verschiedenen Frequenzen hin und her schalten (am Gerät und ohne Rechner), bis was kommt. Darum vermute ich in erster LInie das problem auch am Gerät.

    die Hauptursache für Nicht-Empfang ist, dass die Zeit nicht mehr synchron ist, habe ich mit dem von mir genutzen Rechner auch immer wieder. Zu anfang ging es auch bei mir, weil zufällig gerade die Internet-Time-Synch gelaufen war.

    Diese prüfe ich immer über https://time.is/, wenn es nicht funktioniert und bisher hat es immer gepasst. Wie beschrieben funktioniert das dann nach einigem Hin- und Herschalten. Wenn die Zeit vohrer nicht synchrom gewesen wäre würde das auch bedeuten, dass sich immer grade zwischen dem hin und heschalten die Zeit synchronisiert hat.

    Mein Gefühl sagt mir, dass er nicht sauber / vollständig in die Digi-Mode schaltet ...

    Dennoch nehme ich den Tipp ernst und werde die Zeit zur Synchronisation, wie von Tom beschrieben direkt nach meinem Beitrag in die Praxis umsetzen:

    Regelmässig macht das System das von selbst, wenn es aktiviert ist. Möchte man kürzere Abstände, dann konfiguriert man timesyncd vollständig, d.h. auch die anderen Zeilen auskommentieren und unter ntp eine Liste von funktionierenden ntp Servern eintragen. Man sollte aber die Pollintervalle nicht zu klein machen, manche ntp Server mögen das verständlicherweise nicht. timesyncd fängt aber immer mit den minimalen Werten an, bis die Zeit synchronisiert ist und erhöht dann die Pollintervalle bis zum max. Wert, weil so ungenau sind die Timer heute nicht mehr.

    ich kenne zwei Zustände, die hier passen (könnten). Im Menü unter CW Keyer kann Practice mode aktiviert sein oder der SWR-Schutz (Protection) hat zugeschlagen. In beiden Fällen gibt es auf dem Display einen Hinweis. Rechts von der Frequenzanzeige in der ersten Zeile erscheint der Buchstabe "P" bzw. "S".

    Keines der beiden Zeichen wird auf dem Display angezeigt.

    Es trifft hier wohl nicht zu, kann aber gelegentlich hilreich sein: Auf dem Display gibt es bei digi mode eine Anzeige für das Aktivieren des Tx und das tatsächliche Senden des Tons. Genauers steht im Operating manual unter "Transmit status indication during QMX digital transmissions".

    Richtig und wenn er wieder rumzicket, dann wird auch hier nichts angezeigt - weder die Ansteuerung noch der Sendebetrieb. Gestern habe ich dann noch einige Male mit WSJT-X getestet und ich hatte ganz kurz erst einen Punkt, dann den zweiten Punkt. Den zweiten Punkt (bedeutet, dass er wirklich sendet), vielleicht eine viertel Sekunde, also kaum zu erkennen.

    Zum Betrieb unter Linux gibt es im Operating manual den Abschnitt "Linux special note". (RTFM ;) )

    Den habe ich bereits vor der ersten Inbetriebnahme durchgearbeitet und es funktioniert zwischendurch ja auch immer wieder.

    Im QMX gibt es für jedes Band einen Parameter "Audio Gain". (RTFM Abschnitt "8.5 Band configuration")

    Ah, das hat funktioniert, vielen Dank! Habe bisher nichts an diesen EInstellungen geändert.

    Wird nichts empfangen/gesendet => Soundkarte checken. Es kann vorkommen, daß die Einstellungen weg sind. K.A. warum.

    Wenn Du die Soundkarte Einstellst, dann gleich die vom QMX nehmen, nicht über pulse gehen. Die erkent man in der Auswahlbox. Evtl. das Programm erst nach dem Anstecken starten.

    Selbiges, wenn Cat mal nicht will. Wenn man mehrere USB Geräte hat, selbigen Typs, dann geht es da mit ttyUSBx ttyASMCx schon mal durcheinander.

    Besser ist es, wenn du den eindeutigen Pfad nimmst "/dev/serial/by-id/" und dort natürlich die passende Schnittstelle anfügen.

    Die ist dann meistens fix.

    Ok, das werde ich gleich mal testen und berichten. Ich meine auch, dass ich schon mal den direkten Pfad versucht habe und das dies nicht funktioniert hat. Später dazu aber mehr - muss noch ein paar andere Dinge zwischendurch erledigen.

    Bis später!

    73 Thorsten
    DO1TG

  • Wenn Du den direkten Pfad einträgst,und dann ohne QMX das Programm startest, dann kann es sein, daß die Software das wieder "vergisst".

    Hatte ich auch schon, ich hab viel mit verschiedenen Geräten rumgespielt.

    Bei mir war es eher fldigi.

    73, Jens

    Telegrafie - die einzige Digitalbetriebsart die Analog besser ist.

  • Besser ist es, wenn du den eindeutigen Pfad nimmst "/dev/serial/by-id/" und dort natürlich die passende Schnittstelle anfügen.

    Wenn Du den direkten Pfad einträgst,und dann ohne QMX das Programm startest, dann kann es sein, daß die Software das wieder "vergisst".

    Sehr cool, das hat funktioniert :)

    Den Pegel konnte ich über die KOnfiguration wie von Ludwig beschrieben anpassen. Über den rechner bekomme ich das allerdings nicht hin. Hier mal ein paar Screenshots ...

  • Grade habe ich keine Probleme über WSJT-X - vielleicht Zufall, vielleicht weil ich den Port über die ID gesetzt habe ... das wird die Praxis zeigen. Nun kann ich per Software auf "Senden" gehen und es werden 2 Punkte angezeigt. Das bedeutet, dass die Output-Lautstärke aus dem PC zu gering ist:


    Screenshots habe ich ja bereits geschickt - da gibt es meiner meinung nach keine Option mehr mit der ich die Output-Lautstärke weiter erhöhen könnte...

    Was bekommst Du über den Rechner nicht hin?

    Den Input Level zu erhöhen, stat wie von Ludwig vorgeschlagen den Output des QMX in der Konfiguration von diesem anzupassen

    73 Thorsten
    DO1TG

  • Dann schau mal bei Aufnahmegeräten in den Lautstärkeeinstellungen. Da kann man auch noch aufdrehen.

    Dazu muss aber die Software laufen, sonst nimmt ja keiner auf.

    73, Jens

    Telegrafie - die einzige Digitalbetriebsart die Analog besser ist.



  • So, kurzes Zwischenfazit ...

    Ich habe zwischen den Tests über WSJT-X immer wieder auch das Tenden über die serielle Diagnose versucht ... immer wieder ohne Sendeleistung und ohne SWR.
    Beim Hochdrehen der Lautstärke der Aufnahmegeräte hat er dann ganz gestreikt und dieb eiden Punkte wie zuvor beschrieben wieder nur für einen Bruchteil einer Sekunde angezeigt. Ich habe ich danach Stromlos gemacht, vom USB getrennt und wieder angeschlossen. Nun funktioniert das Senden über WSJT-X. Danach bin ich glerich in die serielle Konsole und habe auch darüber getestet (das hat ja nichts mit den Audioeinstellungen zu tun) und auch hier geht es plötzlich, es wird Power und SWR angezeigt.

    Das meine ich mit rumzicken! Vielleicht ist das Verbindungsproblem und das Problem mit dem Pegel nun gelöst - das muss ich testen. Das Senden ohne Power und ohne SWR allerdings hat damit nichts zu tun und das ist bisher immer sporadisch aufgetreten ...

    73 Thorsten
    DO1TG

  • Vergiss nicht CW vs digimode beim qmx. Ansonsten auf der groupd.io seite mal nachfragen

    73, Jens

    Telegrafie - die einzige Digitalbetriebsart die Analog besser ist.

  • Vergiss nicht CW vs digimode beim qmx. Ansonsten auf der groupd.io seite mal nachfragen

    Klar, das kenne ich ja vom hin- und herschalten bis es funktioniert ;)

    Ja, wenndas "Sendeproblem" nochmal auftritt, dass medeich mich dort ... wenn alles funktioniert kann ich ja keine Tests oder Empfehlungen vornehmen, die mir zeigen, ob damit das Problem gelöst wird ;)

    73 Thorsten
    DO1TG

  • Ja, die ist ganz gut. Man muss mit den Einstellungen ein wenig spielen. Im Textbereich werden Deine Stationen angezeigt, aber keine grafische Ausgabe. Zumindest in meinem Smartphone.

    73 Michael, DF2OK.

    ~ AFU seit 1975 ~ DARC ~ G-QRP-Club ~ DL-QRP-AG GM ~ AGCW ~ FISTS ~ QRPARCI ~ SKCC ~ QRZ.COM ~

    "Lege keinen Wert auf diejenigen, die dich nicht zu schätzen wissen."

  • Den zweiten Punkt (bedeutet, dass er wirklich sendet), vielleicht eine viertel Sekunde, also kaum zu erkennen.

    Hallo Thorsten,

    nehmen wir an, der Sender ist per CAT aktiviert (erster Punkt). Wenn dann der Ton rausgeht, kommt der zweite Punkt. Erst dann zieht der QMX meines Wissens ordentlich Strom. Könnte dieser Stromanstieg ein Problem bei der Spannungsversorgung bringen, vielleicht einen Spannungseinbruch? Bei den Schutzparametern kann eine untere Spannungsgrenze eingestellt sein, bei deren Unterschreitung das Senden unterbrochen wird. Eventuell wird diese Grenze zwar unterschritten, die Betriebsspannung reicht für den Rest des QMX aber aus. Der Controller arbeitet korrekt weiter.

    Bei einem Bekannten wurde zeitweise kein Ton gesendet, weil die NF in WSJTX nicht auf 100% stand (Schieber am rechten Rand).

    73, Ludwig

  • Hallo Ludwig,

    nehmen wir an, der Sender ist per CAT aktiviert (erster Punkt). Wenn dann der Ton rausgeht, kommt der zweite Punkt. Erst dann zieht der QMX meines Wissens ordentlich Strom. Könnte dieser Stromanstieg ein Problem bei der Spannungsversorgung bringen, vielleicht einen Spannungseinbruch? Bei den Schutzparametern kann eine untere Spannungsgrenze eingestellt sein, bei deren Unterschreitung das Senden unterbrochen wird. Eventuell wird diese Grenze zwar unterschritten, die Betriebsspannung reicht für den Rest des QMX aber aus. Der Controller arbeitet korrekt weiter.

    Über die Konsole zeigt er mirja auch die Spannung an und diese bricht zumindest dort nicht ein. Und wie gesagt, jetzt geht es ja prlötzlich wieder ... ich muss mal schauen, wie ich das messen kann - die üblichen Messgeröte sind meiner Meinung nach zu träge für sowas

    Bei einem Bekannten wurde zeitweise kein Ton gesendet, weil die NF in WSJTX nicht auf 100% stand (Schieber am rechten Rand).

    Das geht auch wieder und ich dachte, dass es an den veränderten Lautstärkeeinstellungen lag, allerdings hat sich alles nach dem Abstöpseln und nei dranstecken wieder zurück gesetzt und es hat dann trotzdem noch funktioniert - außer der Pegel vom QMX - den habe ich nun wie von Dir vorgeschlagen über die Konfiguration auf 60 gesetzt.

    73 Thorsten
    DO1TG