K2 : welcher Adapter RS232/USB mit WIN10 ?

  • die FTDI Chips kann ich auch nur empfehlen. Dumm war natürlich, dass der Hersteller mit neueren Treibern die diversen Fakes, die zumindest eine Zeitlang (ist das Problem mittlerweilen wirklich gegessen?) auf dem Markt waren, einfach gebrickt hat, was natürlich extra fies ist gegenüber dem nichtsahnenden Kunden.


    Drum wenn ich auf Nummer sicher gehen will, ordere ich mir eben z.B. den FT232RL direkt bei Mouser, wobei ich als nur-Linux-Anwender nicht in diese Brick-Mine laufen kann.

    Wobei ich denke, wer nicht mit einer SMD Reworkstation ausgestattet ist, fährt wohl besser mit dem FT232BL - mit einem normalen Lötkolben lässt sich das 32er TQFP besser löten als das SSOP des FT232RL


    Breakout-Boards finden sich ja auch fürs TQFP

  • jajaaa...steht alles in den Unterlagen vom K2..... ist ja richtig

    Allerdings habe ich die das letzte Mal vor 21 Jahren im Detail gelesen, als ich den K2 zusammengebastelt habe.

    Mann, Mann, Mann ... ist das schon sooo lange her ?

  • Hallo K2-Nutzer,


    über die Jahre hinweg haben sich, abhängig vom Windows-Betriebssystem, auch bei mir die RS232-USB-Adapter geändert. Vor Windows 10 tat ein Prolific-Adapter gute Dienste. Seit Windows 10 ist es eine Selbstbaulösung. Sie besteht aus einer Mini-USB-Buchse mit integriertem FTDI-Schaltkreis, die eigentlich für die Leiterplattenmontage vorgesehen ist und daher Lötstifte wie eine Sub-D9-Buchse besitzt. Daran habe ich dann direkt einen normalen Sub-D9-Stecker gelötet, der an die Buchse des K2 passt. Das ganze sieht nicht schön aus, daher kein Foto.


    Wie schon hier im Thema geschrieben, darf ein USB-Adapter nicht direkt an die Sub-D9-Buchse am Elecraft angeschlossen werden, sondern nur am PC-seitigen Ende eines speziell verdrahteten Kabels, um so zum Beispiel zusätzlich zur Steuerung durch einen PC eine externe PA anschließen zu können. Da ich jedoch keine PA vom K2 aus ansteuern wollte, habe ich die Leiterplatte des KIO2 nach dem Zusammenbau vor vielen Jahren so modifiziert, dass sich ein RS232-USB-Adapter direkt anschließen lässt, ohne dass etwas auf der Platine den Geist aufgibt. Nach Jahren habe ich es heute endlich geschafft, die Umbauschritte hier festzuhalten.


    72/73 de Ingo, DK3RED - Don't forget: the fun is the power!

  • Moin Ingo,

    genau daran habe ich auch schon gedacht, da bei mir ebenfalls keine PA vorgesehen war und ist. Noch habe ich allerdings keinen neuen Adapter; der Bestellzettel ist noch nicht voll genug :D

    73 Joachim

  • ...und wie der Zufall es will fällt mir doch heute ein merkwürdiges Kabel in die Hände...tataaaa

    ich hatte also doch schon vor Jahrzehnten(!) das passende Adapterkabel zusammengestrickt. Zu meiner großen Freude funktioniert jetzt die CAT-Schnittstelle. Also Glück gehabt.


    73 Joachim

  • Hallo,


    Oh je, das ist alles vergnügunssteuerpflichtig.


    Die Idee eine I/O an den K2 zu basteln, hatte ich gesteckt, aber ich wollte meinen G90 steuern und ein Update machen.


    Die ersten Wochen lief es mit dem mitgelieferten Kabel gut und plötzlich, nach dem letzten Patch von Freund MS, ging der Adapter nicht mehr. Noch schöner: Er tauchte im Gerätemanager nicht mehr auf. Versteckt habe ich ihn gefunden und als ich die Treiber erneuern wollte, war er ganz weg. Diese Abwesenheitsnotiz wiederholte sich an drei Rechnern 2x Win10, 1 x Linux.


    Dann kaufte ich mir ein Kabel bei A. FTDI TTL-232R-3V3-AJ

    Ich schloss es an, Port wurde angezeigt und bevor ich Versuche machte, schickte ich das Update in das Kopfteil: Erfolg!

    Da die Basis auch upgedated werden muss, schaltete ich aus ... Und der Port war verschwunden und das Kabel s.o. wurde im Gerätemanager nicht mehr angezeigt. Sichtbar machen, andere Rechner ausprobieren, das Kabel ist weg, der Port ist weg.


    Ich hatte noch ein teures Kabel von Elecraft FTDI FT232 Serial UART IC . Hier wird der Port angezeigt, ich kann es bei Termpro und in den Eigenschaften einstellen, (115200, 8,1) aber wenn es zur Übertragung kommt, wird im Terminalfenster nur Gibberisch angezeigt = Es funktioniert nicht.


    Jetzt habe ich einen halblebigen G90 und drei Kabel, keine Ideen mehr und schon zwei Tage verbraten. Das macht kein Spass.

    Doch eine Idee: Ich hab nach China geschrieben, aber ...


    Hajo

  • Moin Hajo,


    geh mit der Uebertragungsrate runter! 115.200 funktioniert selten ohne korrektes Hardware-Handshake.


    Ich verwende seit Jahren einen 4-fach USB Seriell mit FTDI Chipsatz ohne Probleme unter Linux und Windows 10.

    https://www.reichelt.de/usb-2-…e&trstct=pos_6&nbc=1&&r=1


    Ich sehe erst jetzt, dass es um Kabel mit 3.5mm Klinke geht. Probiere das mal mit max. 38.400, eher noch weiter runter mit der Uebertragungsrate. Da ist ja definitiv kein Hardware-Handshake vorhanden. Ausserdem ist das kein RS232 sondern TTL, also 0 und 5V oder 0 und 3.3V (mal abgesehen davon, dass es TTL eigentlich nicht mit 3.3V gibt, das waere dann LVTTL), aber nicht -24 bis -3 und +3 bis +24V.


    73, Tom