QCX 20m-Transceiver: Fehlersuche nach Überspannung

  • Hallo,


    gestern habe ich meinen selbstgebauten QCX 20 in Betrieb genommen.


    Zunächst lief alles fast wunschgemäß: Das Menü des Transceivers war vorhanden wie ich es erwartet hatte, der Abgleich funktionierte ebenfalls und der Sender hatte Leistung.

    Der Empfänger war allerdings taub, hier lag noch etwas im Argen.


    Dann habe ich leider einen Kurzschluß verursacht. Vermutlich hat es eine Verbindung gegeben zwischen dem Ausgang des Spannungsreglers 7805 im TO-220-Gehäuse und dem Pluspol der angeschlossenen Spannungsquelle (12 V Bleigel-Akku).

    Das Display hatte danach lediglich die Hintergrundbeleuchtung ohne Text , und der 7805 wurde sofort sehr heiß.


    Nach dem Austausch des Spannungsreglers 7805 zeigt das Display nun für etwa 2 Sekunden den folgenden Text:


    "5W CW Tcvr 1.00f

    QRP Labs, 2018"


    ... und gibt dann eine Fehlermeldung aus:


    "Si5351A error"


    Das Menü ist nicht mehr zugänglich.


    Der Fehler ist bekannt, er wird in der QRP-Labs-Gruppe für den QCX diskutiert. Es soll sich um ein Kommunikationsproblem im System handeln.

    Mit den dortigen Angaben bin ich aber bei der Fehlersuche nicht weitergekommen.


    Für mich stellt sich das so dar:


    Im vorliegenden Fall wurden die Halbleiter bei dem Kurzschluss mit 12 V beaufschlagt anstatt mit 5 V.


    Welche Bauteile sind ggf. betroffen, wie grenze ich den Fehler ein, oder verspricht das Ganze wenig Aussicht auf Erfolg?


    Gibt es ähnliche Ereignisse, oder hat jemand eine Idee für die Fehlereingrenzung?


    73,
    Klaus-Peter

    DJ4DI

  • Hallo Peter,


    potentiell können alle Halbleiter defekt sein, die laut Datenblatt keine 12V vertragen, also alle ICs außer dem LM4562, der wohl bis +/-17V geht.

    Zuerst hätte ich den Si5351A in Verdacht, da hier als absoluter Max-Wert 3,8V Supply spezifiziert sind.

    Kann aber auch ein anderes IC schneller tot gewesen sein. Möglicherweise hat der erste "Todesfall" die übrigen gerettet durch den

    Spannungseinbruch nach dem Stromanstieg.

    Welche ICs hast Du auf Fassungen ?


    Ist die Stromaufnahme mit dem neuen 7805 denn wieder im normalen Bereich oder noch verdächtig hoch ?

    73

    Markus

  • Hi hab grad nochmal in die Schaltung geschaut, check mal die Dioden D1 und D2, ob die noch OK sind,

    bzw. ob der SI5351 seine Versorgungsspannung hat !

    Wenn der SI5351 zu viel Strom gezogen hat, könnten die tot sein. Evt. hat das den SI gerettet - wer weiß


    73

    Markus

  • Hallo Markus,


    danke für deine schnelle Antwort.


    Die Stromaufnahme ist mit dem neuen 7805 wieder so wie ursprünglich, nämlich 110 mA.

    Das stimmt mit den Angaben von QRP Labs überein.


    Lediglich IC2 ist gesockelt, das ist der ATmega328P 28-pin microcontroller.


    Die Spannungen werde ich im Laufe des Nachmittags messen und auch die Dioden überprüfen.


    Ich melde mich wieder mit dem Ergebnis.


    73

    Klaus-Peter

  • Hallo die Runde,


    letztes Jahr so im März hatte ich so ein Gerät wegen gleichem Fehler und Ursache bei mir zur Reparatur. Die Fotos die ich dazu gemacht hatte, sind größer 1MB,

    so dass ich nur kurz in Textform beschreibe. Der QCX hat keinen Schutz , falls am Ausgang des +5V Reglers die Spannung größer als die Eingangsspannung wird.

    Dies kann so durch einen versehentlichen Kurzschluss der Eingangsspannung beim Messen am 7805 geschehen. Jedenfalls hatte der 7805 satten Durchgang und

    alle Bauteile der +5V Schiene erhielten Überspannung. 2 Bauteile haben es überstanden, der ATmega und das Display . Beim Neukauf des Sixxxx auf die Endungen

    der Bauteilbezeichnung achten, nicht alle Typen werden vom ATmega akzeptiert. Die Beschaltung um den 7805 herum habe ich etwas geändert, die Ein-und Ausgangs-

    pins erhielten eine Rückflussdiode. Die Beschaltung mit Stützkondensatoren wurde geändert und erweitert , der ATmega hat nun ein sauberes Startverhalten , keine

    Einschaltfehlermeldung mehr. Zur Reparatur habe ich ein PDF erstellt mit etwa 16MB . Wer dieses Dokument benötigt, bitte über meine

    Adresse : " manfred.weinberg@arcor.de " sich melden .


    73 de

  • Hallo Manfred,


    auch dir herzlichen Dank für die schnelle Antwort.


    An der Dokumentation zur Reparatur bin ich sehr interessiert. Ich schreibe dir nachher eine E-Mail.


    Eine kleine Unachtsamkeit beim Messen, und schon war es passiert. Aber vielleicht bekomme ich das ja wieder hin.


    @ Markus: Ich komme heute Nachmittag wegen anderer Erledigungen nicht zum Messen, werde mich aber bestimmt melden.


    73

    Klaus-Peter

  • Hallo die Runde,


    habe alle bisherigen Anfragen beantwortet. Sollte irgendwie oder wo etwas unter gegangen sein, noch mal nachfragen.


    73 de

  • Hallo die Runde,


    ich hatte bei einigen persönlichen Antwort-mails geschrieben, dass man in den Bauteilbeschreibungen zu der Serie 78xx nach schauen möchte zur Beschaltung

    der Bauteile. Habe mir einige Unterlagen heruntergeladen, Überraschung , von einer Rückflussdiode nichts mehr zu finden . Bei einem ähnlichen Regler , LM317 ,

    habe ich dazu angaben gefunden . Nun habe ich mein Ersatzteillager durchsucht , einige 5V Regler unterschiedlicher Hersteller genommen und den Test gemacht.

    Eingang kurzgeschlossen und an den Ausgang Spannung angelegt , von 6 Stück ist einer defekt gegangen . Da kann sich jeder jetzt überlegen, ob er seinem Gerät

    noch eine Diode 1N400x spendiert , oder er vertraut darauf dass es wie bis her schon gut gegangen ist.

    Oft finde ich bei Reparaturarbeiten, dass diese Regler keine " direkten " Stützkondensatoren an den Anschlüssen haben, sondern die davor und nachgeschalteten Elkos

    sogar mehr als 5cm entfernt montiert sind. Diese Elkos oft mit 85grd haben dann sogar eine Kapazität von 220µF und höher . Die Folge ist der Elko wird alt , das IC fängt

    an zu schwingen und die nachfolgenden IC können kaputt gehen , geschweige die Technik funktioniert noch sicher .

    Meine Empfehlung , direkt an den Regleranschlüssen entsprechende Stützkondensatoren einsetzen. Entsprechend dem vorhandenen Platz könnten so etwa 100nF Keramik-C

    oder 1µ Tantal , 2,2µ Standart-Elko sein .

    Die Entscheidung muss jeder für sich treffen, ich kann nur ein wenig mithelfen, dass nicht zu viel defekt geht.


    73 de

  • Hallo,


    noch ein Nachtrag von mir dazu:

    Jeder IC-Hersteller liefert zu seinem Produkt ein passendes Datenblatt. Man sollte natürlich tunlichst darauf achten, dass man wirklich das richtige Datenblatt hat und nicht das eines anderen Herstellers oder eine veraltete Version o.ä.

    Ob ein Linear-Regler Elkos oder Keramik-Cs benötigt und wie groß diese sein müssen, ist immer genau angegeben. Manche Regler sind auch völlig ohne externe C's stabil und schwingen nicht! Ebenso benötigen viele Regler schon lange keine extra-Diode mehr zwischen Ein- und Ausgang, falls doch dann steht auch das im Datenblatt.

    Wohlgemerkt, ich meine nicht 30 Jahre alte Teile aus der Bastelkiste, sondern aktuelle Produkte (auch wenn es den Typ vielleicht schon 30 Jahre gibt unter der Bezeichnung).

    Viele Dinge können nix schaden, sie sind aber oft auch gar nicht nötig.


    73

    Markus