Wer hat Erfahrung mit dem Radioberry-HAT ?

  • Hallo Leutz;

    Ich habe hier massive Probleme beim Kompilieren der Software für das Radioberry-Board.

    Aber es ging schon bei der Hardware los:

    Die im Moment erhältlichen Boards sind entweder nur als Leerplatine zu kriegen

    die benötigten ICs so gut wie gar nicht zu finden,

    oder man bestellt sich ein bestücktes Brett in Fernost.

    Da ist leider der Nachteil, dass die die GPIO-Leiste nicht durchgeführt sondern nur als Stecker anbieten.

    Dann hat man ein Problem, wenn der Raspi auf einer SSD-HDD-Adapterplatine sitzt, und seinen Strom von dieser bezieht.

    Hab mit sehr zittrigen Pfoten auf dem Radioberry ein Käbelchen angelötet, soweit - so gut...

    Hat schon jemand anders das Radioberry in Betrieb genommen?

    Es tun sich nach jedem Kompilationsversuch weiter Hürden auf, zieht ein unglaubliche Krämerei nach sich.

    Wenn man dann glaubt, alle benötigte Zusatzprogramme zu haben, ist man nicht sicher, ob die Reihenfolge de Installationen auch die richtige war.

    Ich hab den Raspi inklusive seiner eigentlichen Betriebssoftware schon 3 mal neu aufgesetzt, weil durch undurchsichtige Seiteneffekte das BS zerhackstückt wurde.

    Leider finde ich keine Möglichkeit, den Erfinder des Boards - PA3GSB- direkt zu kontaktieren, um die lange Liste der gescheiterten Versuche mit der Bitte um Deutung der Fehler zu besprechen.

    Ich finde, dass alleine das Makefile ein paar Verbesserungen bräuchte, was aber außerhalb meine Fähigkeiten liegt.

    Als ich das erste Mal von dem Projekt las, war ich hellauf begeistert, hab mir dieses doch etwas teure Board besorgt, und im Web stundenlang gegraben, um Input dazuzubekommen.

    Ich fand dutzende Lobhudeleien, und begeisterte Danksagungen , aber keinen, der die gleichen Probleme wie ich hatte.

    Für Tipps und Hilfe wär ich sehr dankbar.

    Edited once, last by DC7FB ().

  • Moin,


    da fehlen aber eine Menge Informationen, um Dein Problem einzuordnen. Ich habe zwar kein solches Teil, aber ein Blick auf Github hilft.


    GitHub - pa3gsb/Radioberry-2.x: Ham Radio hat for Raspberry PI
    Ham Radio hat for Raspberry PI. Contribute to pa3gsb/Radioberry-2.x development by creating an account on GitHub.
    github.com


    Es sind nicht viele Schritte, aber das Projekt ist 4 Jahre alt, es sind zwar ein paar neuere Dinge dabei, aber trotzdem muss man da schauen. Ist auf jeden Fall kein Plug‘n‘Play Projekt.


    Funktioniert denn überhaupt der erste Schritt mit apt update und die Installation der erforderlichen Pakete? Wenn es dabei schon Fehler gibt oder die Pakete gar nicht existent sind, weil zu alt (ich habe jetzt keine Lust das mit dem iPhone zu prüfen) brauchst Du gar nicht erst weiter zu machen.


    Erste Anlaufstelle wäre dann Github mit dem Bugtracker, wo man Fragen stellen kann.


    Was ich bei dem Projekt vermisse, ist die Nennung der Debian Version und der Kernelversion. Denn es geht um Kernelmodule, wenn da Abhäbgigkeiten bestehen, die es im aktuellen RaspianOS, basierend auf Debian 12 nicht mehr gibt, musst Du den Code anpassen oder auf eine alte OS Version gehen. Wobei ich im Repo einen Ordner für den Pi 5 gesehen habe.


    Also mehr Infos wären schon gut, dann könnte ich zumindest beurteilen, warum es nicht geht.


    73, Tom

  • Und diese Adresse geht nicht?
    PA3GSB@AMSAT.ORG

    Aber wie Tom schon bemerkte: In Deinem recht blumigen Rant sind leider keine konkreten Informationen enthalten.
    Für eine zielführende Diskussion mit PA3GSB benötigst Du:
    Alle Daten deiner Software Umgebung (OS, compiler, libraries), Versionen, Release, uname -a, dmesg
    Welche Befehle Du eingegeben hast (nicht paraphrasieren sondern copy und paste)
    Welches Ergebnis Du erwartet hast
    Welches Ergebnis herausgekommen ist (und wieder nicht paraphrasieren sondern copy und paste)
    Falls z.B. beim Booten copy und paste nicht geht: screenshots
    Die Ergebnisse von configure
    Den kompletten compile und linker log
    Das wäre schon mal ein Anfang
    Viel Erfolg

    73 de Eike KY4PZ / ZP5CGE

    Wat de een sien Uhl is de anner sien Nachtigal
    Auf Englisch: Live and let live
    Und wenn's garnicht anders geht: "Einfach gaanich injuriern!" sagt der Hamburger

  • Wie hat sich das "Zerhacken" des BS geäussert?

    Läuft das OS auf SSD oder SD-Card

    73, Jens


    Und immer schön locker bleiben.

  • Also:

    Es wird ein Raspberry 4 mit 2 GB mit einem aktuellem BS -Bookworm Debian = "2024-03-15-raspios-bookworm-arm64-full.img.xz" benutzt.

    Das grundlegende - Aufspielen des BS geht ohne Probleme vonstatten. Hab mir ein Kabel mit 2x USB-A zum Bearbeiten der SSD am Linux-PC erstellt.

    Auch die Umstellung "Booten von USB" anstelle SD-Card ohne Probleme.

    Anschließend Kontrolle, ob alle für die Kompilierung notwendigen Programme vorhanden - Vorhanden.

    Danach erster Versuch, das Radioberry-Prg aufzuspielen. "https://github.com/pa3gsb/Radioberry-2.x.git"

    Schneller Stop, da PIGPIO fehlte - was aber nicht im REad.me der obigen Software. Dies wurde dann nachgeholt, erzeugte aber weitere Fehlermeldungen.

    Danach stürzte das Raspberry-BS ab, vermutlich weil es bei dem Aufspielversuche Fehler beim Schreiben auf die SSD gab.

    Bei einer Kontrolle der SSD fanden sich gelöschte sowei unlesbare Files. SSD dann am Linux-PC als EXFAT neu formatiert

    Danach erneuter Versuch: ERst Das Raspberry-BS, dann PIGPIO, danach folgens abgearbeitet.

    Quote

    Building

    Install dependencies

    Code
    sudo apt-get update
    sudo apt-get install git libpulse-dev libgtk-3-dev libasound2-dev libcurl4-openssl-dev \        libusb-1.0-0-dev raspberrypi-kernel-headers device-tree-compiler pigpio

    Obtain the source codes

    Code
    cd /tmp
    git clone --depth=1 https://github.com/pa3gsb/Radioberry-2.x.git
    cd Radioberry-2.x
    git submodule update --init --recursive --depth=1

    Build the software

    Code
    make -j$(nproc)

    Installation

    Code
    sudo make install FPGATYPE=CL016

    Dann las ich im WIKI, dass auch noch PIHPSDR gebraucht wird. Download, danns ins entprechede Dir, mit Filemanager nachgeschaut, Ok, make ist drin, dann dieses Verzeichnis im Terminal aufgerufen.
    Beim ersten aufruf wurde das MAkefile nciht gefunden, beim z weiten Versuch stürzte Raspi ab.

    So, das mal als erst Portion; weiters zu diesem Misere folgt.

  • Wie hat sich das "Zerhacken" des BS geäussert?

    Läuft das OS auf SSD oder SD-Card

    BS= OS läuft auf SSD

    Files ncijt lesbar oder angeblich nicht vorhanden, oder einfach Arbeitsverweigerung, noch nicht mal die LED der SSD flackert, reagiert auch nicht mehr auf Tastatur, nur Stecker ziehn geht .

  • @ KY4PZ :

    Die Adresse von Johan- PA3GSB bei Amsat habe ich bisher nicht gefunden.

    NAchfrage: ICh bin zwar 3/4 Italiener, aber schon seit 65 Jahren in DE und auch der deutschen Sprache mächtig; aber erkläre mir bitte, was ein "blumiger Rant" ist.

    Und was meinst du mit "(nicht paraphrasieren sondern copy und paste)" ?

    Was "copy und paste" ist, weiß ich schon seit ich mich mit ZX81 und C64 herumgeärgert hab, aber was sagt "paraphrasieren"?

  • Steckt die SSD am USB3?

    Wenn ja, dann mal Image neu drauf und am USB2 betreiben.

    Es gibt da oft Inkompatibilitäten.

    73, Jens


    Und immer schön locker bleiben.

  • Moin,


    wie die Befehlszeilen lauten, steht ja in der Anleitung, aber Du hast die Frage nicht beantwortet: Funktioniert die Installation der Pakete mit apt install oder gibt es dabei schon Fehler? Wenn ja, dann brauchst Du gar nicht erst weitermachen, sondern muss klären, welche Versionen der Pakete die Software benötigt und dafür musst Du eine Entwicklungsumgebung erstellen, unabhängig vom installieren OS.


    Da Du erst schreibst, dass alle erforderlichen Pakete vorhanden sind und dann das pigpio fehlte, hast Du definitiv schon ein Problem mit apt install gehabt, denn das Paket soll da mit installiert werden. Da hast Du dann Deinen Showstopper. Da nützt es auch nichts, irgendein pigpio zu installieren, ausser Du erstellst das aus den Sources passend für Bookworm.


    73, Tom

  • Quote

    Da Du erst schreibst, dass alle erforderlichen Pakete vorhanden sind und dann das pigpio fehlte, hast Du definitiv schon ein Problem mit apt install gehabt, denn das Paket soll da mit installiert werden. Da hast Du dann Deinen Showstopper. Da nützt es auch nichts, irgendein pigpio zu installieren, ausser Du erstellst das aus den Sources passend für Bookworm.

    Ich bin erst durch den Stopper bei der Inst des Radioberry-Paketes drauf gestoßen, dass pigpio nicht da war. Meine aussa<age, dass alle erforderlichen PAkete da seine, bezog auf Infostand VOR Inst des Radioberry-Packs und darauf, das alles für einen Kompilationsvorgang nötige Soft vorhanden. Nach dem Abbruch habe ich das Terminalfenster nach dieser pigpio durchsucht und dann die Quelle selsbt geholt.. Damit klappt die Inst unter Bookworm ohne Fehlermeldung..

  • Jetz fang ich an zu überlegen, ob bookworm die richtige Grundlage für Radioberry ist,

  • Warum nimmst Du nicht einfach die Software die im Repo ist?

    Wenn die Software fehlt beim Kompilieren, dann musst du die *-dev Pakete installieren.

    73, Jens


    Und immer schön locker bleiben.

  • Ich hab die Software ohne Probleme installiert bekommen.

    Wenn man nach der Anleitung bei github geht, da muss man nur 1 paket aus dem Repo nachinstallieren und wdsp von github.

    Dann läufts durch und lässt sich installieren.

    73, Jens


    Und immer schön locker bleiben.

  • Warum nimmst Du nicht einfach die Software die im Repo ist?

    Wenn die Software fehlt beim Kompilieren, dann musst du die *-dev Pakete installieren.

    Mal ganz ehrlich?! Was glaubst Du, habe ich gemacht?

    Was anderes als erstmal das Radioberry-Paket zu installieren soll ich denn tun?

    Überall , also WIKI uns so, reden allen davon, dass es so oooo einfach wäre. Also hab ich es auch einfach so getan!

    Ich habe keine Paket- was nur so aussah wie Radioberrry genommen. ICh hab es von der GITHUB-Seite von PA3GSB runtergeladen.

    WAS ICH ABER GEMACHT HABE : _Ich habe vorher kontrolliert, ob ich alle notwendigen Werkzeuge zusammen hab.und das BS per update/upgrade auf den neuesten Stand gebracht

    Jetzt denke ich, Du meinst, ich hab falsches Repo benutzt oder vorher dran gefummelt? Reden wir beide von gleichen Github-Paket ?

    Wenn ich richtig lese, dann werden die *.dev Pakete doch vorher von dem Radioberry-Paket selbst installiert, oder ?

    Warum kommen bei Benutzung des offiziellen Repos dann die MEcker wegen PIGPIO und wspr, cl16 usw ?

  • DD5NT;

    Fragen wir mal so:

    Welches BS und was für ein Raspberry hast du?

    Arbeitet dein Raspberry auch mit einer SSD am USB3 Port?

    Ich hab hier ein Board, das eine SSD zu USB3 übersetzt

    Welches Repo hast du benutzt? Ich habe " https://github.com/pa3gsb/RadioBerry-2.x"

    Ein Teil meine Info kommt von "https://saure.org/cq-nrw/2023/07/31/radioberry-hf-sdr-transceiver-pi-hat-er-ist-wieder-da/"

    Dann mit diesem Script begonnen:


    Und da stolpert make erneut

    Hier mal die Terminal-Ausgabe:

    Code: [Auswählen]

    in dem Verzeichnis " sbc/rpi-4/device_driver/driver/ existiert dieses "radioberry.ko" nicht.

    Es kommt immer wieder vor, dass das Script angeblich fehlende Files nicht findet! Geht man aber zufuß dorthin, ist es doch da .

    Kannst Du Dir vorstellen, dass einem da die Wut packt?

    Leider han ich morgen keine Zeit, weil ich zu Behandlung in Krankehaus muß, aber ich hab ein neuen Raspi4 mit 8 GB organisiert. WErde alles ncoh mal neu aufsetzen. Vielleicht ist meine Raspi ja doch defekt.

    Edited once, last by DC7FB ().

  • DC7FB:

    Ich rede von dem im ersten Post verlinktem https://github.com/pa3gsb/RadioBerry-2.x

    Wie hast Du herrausgefunden, was Du alles benötigst?

    pigpio wird ja mit apt mitinstalliert, also kann es nicht fehlen.

    Ich hab nur die Anleitung bei github c&p 1:1 nachgemacht. Nur fftw3-dev mit apt instalkliert und wdsp von Github und installiert.

    Nicht alle nötigen Pakete werden von "radioberry" installiert. Deswegen steht das ja auch welche Pakete mit apt installiert werden müssen. Daß da nicht immer alle pakete stehen, naja, das ist leider oft so.

    Btw: "sudo ldconfig" ist bei manuellen installationen von libs nötig (afair).


    Was mich aber wundert, bei Dir wird wdsp durch radioberry installiert. K.A. was hier los ist.


    Bei deinem letzten Post, Zeile 19. Das erstmal beheben, und dann weiter.

    Es ist nicht immer einfach, vor allem als Linuxnoob.

    Sei froh, daß keine KDE libs benötigt werden.

    Da fehlt libqt5xyt und installiert werden muss libqtxyzqt5. Die spinnen richtig.

    73, Jens


    Und immer schön locker bleiben.

  • Moin,


    ist ja spassig hier.

    in dem Verzeichnis " sbc/rpi-4/device_driver/driver/ existiert dieses "radioberry.ko" nicht.

    Es kommt immer wieder vor, dass das Script angeblich fehlende Files nicht findet! Geht man aber zufuß dorthin, ist es doch da .

    radioberry.ko ist das Kernel Modul, welches erst erstellt wird.

    Code
    make: *** Es wird auf noch nicht beendete Prozesse gewartet....
    gcc -g -O3   -c -o measure.o measure.c
    gcc -g -O3   -c -o radioberry.o radioberry.c
    cc -I /include -I /include/linux  -g -fPIC -O3 -D _GNU_SOURCE       -c -o amd.o amd.c
    In file included from linux_port.c:29:
    comm.h:50:10: fatal error: fftw3.h: Datei oder Verzeichnis nicht gefunden
       50 | #include "fftw3.h"
          |          ^~~~~~~~~
    compilation terminated.

    Hier steht doch eindeutig, warum radioberry.ko nicht erstellt werden konnte. Wenn Du schreibst, das Makefile wäre verbesserungswürdig, solltest Du erst mal verstehen, was das Makefile macht und was die Ausgaben bedeuten.

    Es ist nicht immer einfach, vor allem als Linuxnoob.

    Sei froh, daß keine KDE libs benötigt werden.

    Da fehlt libqt5xyt und installiert werden muss libqtxyzqt5. Die spinnen richtig.

    Das hat mit Linux überhaupt nichts zu tun, Du könntest die Software unter jedem Betriebssystem mit der GNU Toolchain erstellen und dann auf einem Raspberry installieren. Das hat nur etwas mit dem Verständnis von Softwareentwicklung mit der GNU Toolchain zu tun.

    Kannst Du Dir vorstellen, dass einem da die Wut packt?

    Ich zitiere mal PA3GSB, da steht etwas von lernen und Du kannst an Hand von seinen Daten jeden Schritt nachvollziehen und davon lernen. Dazu muss man aber auch lesen, nämlich die Dokumentation der GNU Tools:

    Quote

    The radioberry is not a project you should start when you want a finished product.

    I started the project for myself. Decided to publish everything i have learned.


    Wie ich schon am Anfang schrieb und was von Eike noch ergänzt wurde, wenn Du Hilfe willst, liefere die Daten gleich und nicht erst im 17. Beitrag. Die Lösung für das Problem hat Jens Dir genannt. Du kannst im Terminal das Logging aktivieren, mit 'history' kannst Du alle Eingaben noch mal abrufen, die Du gemacht hast. Die Files hättest Du einfach anhängen oder mit Copy&Paste hier einstellen können, dann hätte ein "ich habe ein Problem mit radioberry nach Anleitung zu erstellen, das sind die Ausgaben, wer kann helfen" genügt. Das ist übrigens das, was Eike mit "blumiger Rant" und "paraphrasieren" meint, nicht alles blumig mit eigenen Worten umschreiben, sondern die Logs liefern. Das hilft viel mehr weiter, als aus zig Beiträgen die paar Sätze mit der relevanten Information zu suchen. Deshalb fragte ich schon im Beitrag #2 danach.

    aber ich hab ein neuen Raspi4 mit 8 GB organisiert. WErde alles ncoh mal neu aufsetzen. Vielleicht ist meine Raspi ja doch defekt.

    Ja, das ist sicher sinnvoll :saint:


    73, Tom