FiFi und W10

  • Hilfe! Ich bekommen meinenFiFi (m. Preselektor) nicht mehr zum Laufen

    Hatte W10 neu aufgesetzt und will nun auch wieder sdr hören/sehen. Habe die Treiber von Zadig draufgespielt und die SDR-Console V3 bietet sie mir dann auch an. Nur leider kommt dann nur Rauschen und in der Mitte vom Bildschirm ein dicker Balken. Im Geräte-Manager taucht die Soundkarte von FiFi nicht auf. Hatte die Eingänge schon mal deinstalliert - ohne Erfolg. Was könnte ich noch machen? Es lief ja schon mal. Bei Kaspersky hab ich auch "grünes Licht" gegeben.

    Gruß und schönen Sonntag, Bernd.

  • Kann überflüssige Frage sein, aber: nicht nur als Admin logon, sondern auch mit Adminrechten explizit die Installation gestartet (Aufruf rechte Maustaste im Popup)?? War bei den RTL-Sticks immer wieder der Renner - weil man es oft einfach vergißt, man ist ja schon Admin ......... Die Installation meckert ohne Adminrechte nix an, aber hinterher is dafür auch nix ......


    73 Peter

  • Danke Peter,

    hat leider nichts gebracht. Hab gerade die Treiber vom FIFI gelöscht, dann Stecker raus u. wieder rein. Er hat sich selbst die Treiber wieder installiert aber die Console erkennt ihn nicht. (über "definitions - Search- softrock- si750" keine Installation gefunden. Meinen RTL-Dongel bekomme ich problemlos zu laufen. Ich grabe mich mal weiter durch! Gute Nacht, Bernd.

  • Hallo Ulli,

    nach diesem link gehe ich ja auch brav vor, nur erscheint im linken Kästchen wo (NONE) stehen sollte immer libusb... !?!

    Ich grabe mal weiter. Ging ja schon mal, hi.

    Schönen Sonntag, Bernd.

  • Gibt es evtl. die Treiber/Zadig auch für/mit Win 64bit ?? Wenn ja, probieren.... 73 Peter

  • Hallo Bernd,


    im linken Kästchen steht bei Zadig immer welcher Treiber für das Gerät gerade installiert ist. NONE steht dort nur wenn du noch nie etwas installiert hast.


    Zadig kann nur die libusb-Treiber installieren. Andere Treiber können damit nicht installiert werden.

    Ich habe z.Zt. hier keinen Windows 10-Rechner und kann daher nur in Windows 7 nachschauen:

    Kannst du nicht über den Windows-Gerätemanager bei den betroffenen Geräten den Treiber aktualisieren? In Windows 7 ging das über "rechte Maustaste" --> "Treibersoftware aktualisieren" --> "Auf dem Computer nach Treibersoftware suchen" --> "Aus einer Liste von Gerätetreibern auf dem Computer auswählen". Dort solltest du ein "USB-Audiogerät" (oder so ähnlich) angeboten bekommen. In Windows 10 sollte das doch ähnlich funktionieren. Aber wie gesagt habe ich hier gerade kein Windows 10 auf dem ich nachschauen könnte.


    Danach kannst du ja nochmal mit Zadig schauen ob der libusb-Treiber nur bei den einen Gerät installiert ist.


    73,

    Uli DF7SC

  • Gibt es evtl. die Treiber/Zadig auch für/mit Win 64bit ?? Wenn ja, probieren.... 73 Peter

    Nein, nicht Zadig für die FiFi-Soundkarten verwenden. Das Problem ist meiner Ansicht nach, dass mit Zadig der libusb-Treiber für die FiFi-Soundkarte installiert wurde. Dort muss jetzt wieder der original Windows-Soundkartentreiber rein.


    Nachtrag:

    Ich habe gerade gesehen dass es auch auf der Webseite von Zadig eine Beschreibung gibt wie man versehentlich installierte libusb-Treiber wieder deinstallieren kann:

    FAQ
    Windows Driver Installer library for USB devices . Contribute to pbatard/libwdi development by creating an account on GitHub.
    github.com

    Wichtig ist dabei den Haken bei "Delete the driver software for this device." zu setzen.


    73,

    Uli DF7SC

    Edited once, last by DF7SC ().

  • Hallo,

    vielen Dank für eure Tipps! Es gelingt mir nicht, den FIFI als Soundkarte zu betreiben. SDR console läuft nur, wenn ich die libus treiber von Zadig verwende. Nur kommt dann dieses Bild:

    Ratlose Grüße, Bernd.

  • Hier mit RTL-Dongel:

    Musste aber die Treiber auch von Zadig laden. Hab meine gute alte Grahn-Antenne, GS3-SE dran!

    Bernd

  • Hallo Bernd,


    lass mal den Vergleich mit dem RTL-Dongle. Dies ist eine andere Hardware die nicht mit den Windows-Soundtreibern betrieben wird.


    Schau dir nochmal deinen Beitrag #3 an. In dem Screenshot sieht man, dass du auf deinem FiFi-SDR noch eine alte Firmware hast. Dein FiFi-SDR erscheint als USB-Verbundgerät mit zwei Interfaces. Es erscheint daher im Windows als zwei Geräte, die auch in diesem Fall mit zwei unterschiedlichen Treibern betrieben werden müssen. Das Interface 0 (das heißt bei deiner alten Firmware "SoftRock SDR") muss mit dem libusb-Treiber betrieben werden. Dieser Treiber wird mit Zadig installiert. Das Interface 1 (das heißt bei dir "FiFiSDR Soundcard") muss mit dem Windows-Soundtreiber betrieben werden, also darf Interface 1 auf keinen Fall mit Zadig bearbeitet werden. Wenn das so korrekt installiert wurde dann siehst du im Gerätemanager (Start-Menü rechte Maustaste --> Gerätemanager) zwei Geräte. Eines mit dem Namen "SoftRock SDR" und das andere Gerät als Soundkarte mit dem Namen "FiFiSDR Soundcard".


    Da bei dir jetzt das Interface 1 auch mit dem libusb32-Treiber installiert ist musst du diesen Treiber entfernen und löschen. Danach am besten Windows mal neu starten. Dann sollte beim neuen Anschliessen das Interface 1 vom Windows automatisch als Soundkarte installiert werden. Du darfst also mit Zadig ausschliesslich das Interface 0 bearbeiten.


    Lass dich nicht davon verwirren dass das Interface 0 deines FiFi-SDR im Windows "SoftRock SDR" heißt. Das liegt an deiner alten Firmware auf deinem FiFi-SDR. Mit der aktuellen Firmware des FiFi-SDR hätte er den korrekten Namen FiFi-SDR. Ausserdem würdest du dann noch zusätzlich ein Interface 3 sehen (auch eine Soundkarte mit dem Namen "FiFi-SDR AM/FM/SSB Receiver"). Wenn aber dein FiFi-SDR schon mal mit der alten Firmware in Windows 10 betrieben werden konnte, dann würde ich das jetzt erstmal nicht ändern.



    73,

    Uli DF7SC

  • Danke Uli,

    aaaber, ich kriegs nicht hin! Bei FIFI - Treiberaktualisierung kann ich hier auswählen. Hab den Ersten genommen. Ohne Erfolg.

    Falls ich mich recht entsinne, müsste auch das Mikrofon mitspielen. Bei mir sieht es aber so aus:

    Ich setz' mich jetzt erstmal zum Entspannen an die Morsetase!

    Vy 73! Und vielen, vielen Dank für deine Mühe!!!

  • Danke Uli,

    aaaber, ich kriegs nicht hin! Bei FIFI - Treiberaktualisierung kann ich hier auswählen. Hab den Ersten genommen. Ohne Erfolg.

    Hallo Bernd,

    das war der Falsche. An deinem Screenshot sieht man dass du inzwischen schon sehr viele unpassende Treiber im System hast.

    Der richtige Treiber für die Soundkarte des FiFi-SDR (Interface 1) heißt im Windows "USB-Audiogerät". Das habe ich schon in meinem Beitrag #8 geschrieben.


    73

    Uli DF7SC

  • Es gibt via USBDeview eine sehr gute Möglichkeit, sich die installierten und aktiven Treiber anzusehen, mit jeder Menge Infos. Man kann dort auch unpassende Treiber (USBDeview im Admin-Mode aufgerufen) direkt entfernen, bzw. "uninstall device". Ich habe zu RTL-Stick-Tohowabohu-Zeiten die Treiber für Tests lieber renamed. USBDeview war mir sehr oft eine super Hilfe. Man sieht auch sehr deutlich, welche Info das USB-Teil liefert.


    https://www.nirsoft.net/utils/usb_devices_view.html download, unzip, fertig.

    Gruß Peter

  • Hallo,

    hab ALLES (?) brav probiert, leider noch kein Schimmer eines Erfolges. Peter, ob ich mich an das tool rantraue weiß ich noch nicht. Erst wenn gar nichts mehr hilft! Z. Zt. sieht es so aus: Keine Spur eines Signals.

    73, Bernd.

  • Bernd,


    mal eine dumme Frage: Warum hast Du das System überhaupt neu intalliert? Langeweile oder gab es einen speziellen Grund?


    73 Andreas DF2TB

  • Peter, ob ich mich an das tool rantraue weiß ich noch nicht.

    Das Tool ist ungefähr so gefährlich für Deine Installation wie ein Kombi-Luftdruck-Temperatur-Feuchtigkeits-Meßgerät offline im Shack. Ruf es doch einfach mal auf, es ist nichts zu installieren, ein reines Display-Tool, solange Du nicht aktiv löschen o.ä. willst. Du kannst um einiges übersichtlicher als im Devicemanager sehen, was an USB am PC hängt und wer (Treiber) es bedient.


    Du hast doch nach allen Berichten hier vermutlich ein Treiber-Problem. Verschaffe Dir doch da erst mal eine Übersicht. Die aktiven USB-devices sind farbig hinterlegt, pro USB Interface - wenn ein USB mehrere bedient. Damit kannst Du bestens überprüfen, ob das was Du meinst installiert zu haben, auch wirklich drin und aktiv ist. Eine lange Zeile pro Interface, im rechten Teil die Treiber, die aktuell aufgerufen wurden (nicht nur "installiert").


    73m Peter

  • mal eine dumme Frage: Warum hast Du das System überhaupt neu intalliert? Langeweile oder gab es einen speziellen Grund?

    W10 wurde nicht mehr fertig, sich selbst zu reparieren. Hab' s dann online neu aufgesetzt.

    Es gibt einen link, in dem beschrieben wird, wie man bei w10 die Treiberinstallation erzwingen kann. Hatte ich gestern mal probiert aber erstmal ohne Erfolg.

    dl1amq_installationshinweise.pdf

    Ich bleib dran!

    73, Bernd.

  • Hallo Peter,

    hab das tool von einer anderen side runtergeladen. Die von dir vorgeschlagene side war mir zu verschwiemelt, sri. Das Ergebnis stell ich mal hier ein. Mir fehlt Erfahrung, besser gesagt ich habe keinen Schimmer einer Ahnung.


    Was kann ich jetzt tun?

    73, Bernd.