µSDX – Ein Mikro SOTA SSB/CW SDR Transceiver mit Arduino!

  • Hallo Zusammen,


    Sorry ich schaue hier nur ab und zu vorbei. groups.io hält mich genug auf Trab, und dann gibt es da ja noch so Nebensächlichkeiten wie Beruf, Famile ;)


    Zu dem Fragen:

    Wolfgang / DH1AKF:

    Ich hatte Dir ja schon auf groups.io geantwortet. Im Moment ist nichts in diese Richtung geplant.

    Wir (Guido und Ich) haben Pläne in Richtung HF + 2m/70cm aber das wird ein neues Projekt und vermutlich nicht mehr Open Source.


    @Nick, DL5XJ:

    Es gibt nicht DAS Hex File. Es müssen ein paar Sachen eingestellt werden, je nachdem welche Hardware Du verwendest. Für die Platinen, die Uli verteilt hat, hänge ich mal was passendes an. (LCD Display, 5 Band Version, kein CAT


    @ Uli, DF5FS:

    Bist Du voran gekommen mit Deinem Problem ?


    73 Manuel; DL2MAN

  • @ DL2MAN: Danke, Manuel, die hex-Datei problemlos aufgeladen.


    Trotz aufgespielten FW läuft das Gerät bei mir noch nicht. Ich vermute es liegt am LCD-Display, das ich als gebraucht aus einem anderen Projekt "ausgeliehen" habe. Das wird sich bald klären.

  • Hallo Nick,

    zur Fehlersuche habe ich mir eine Adapterplatine mit 4 Steckleisten zusammengebaut. Hat mir schon sehr geholfen.



    @Manuel: Mit "meinem" Problem hab ich mich noch nicht richtig beschäftigt. Kommt noch.

  • Frohe Weihnachten allen Lesern,


    pünktlich zum Festbeginn ist mein uSDX fertig. Sogar erste QSO auf 40m gelungen, S58MU gab mir 559 in CW.

    Falls jemand Lust auf 2-way-uSDX QSO hat, bitte melden .. ;)

  • Herzlichen Glückwunsch - da bin ich noch "meilenweit" entfernt....


    Einer der ersten uSDX die am OQRP-Test teilnehmen werden ???


    An alle frohe Feiertage

  • Hallo,

    Herzlichen Glückwunsch zum ersten uSDX QSO Nick.


    Auf dem Labortisch funktioniert bei mir (fast) alles - mir fehlt nur noch eine 40m Antenne auf dem Balkon.

    Hier habe ich mich von ON6WG inspirieren lassen. Spule vom Flohmarkt ist vorhanden.

    Im OQRP-Contest wird man mich dann für ein paar Stunden mit dem uSDX auf 40m hören(?)/arbeiten können.


    Ausgangsleistung in CW sind 5W (50 Ohm/40m/12V). Dazu musste die Spule Lc2 auf 9 Wdg. geändert werden.


    @Nick: Hat bei dir TX Drive/PA Bias min/PA Bias max Einfluss auf die Ausgangsleistung?


    BLEIBT GESUND !!

  • Hallo Uli & alle zusammen,


    @ Uli: TX drive und PA Bias min haben hier keine sichtbare Funktion. Vermutlich sind die Einstellungen nur für SSB relevant. PA bias max verändert Pout in CW von ca. 2 auf 4 Watt (Angaben sehr ungenau).


    Was mir zur Zeit etwas fehlt, ist bessere Beschreibung der einstellbaren Parameter im Menu.

    Menu 8.1 "27 MHz actual Xtal " heute justiert. Ohne hochomigen Probe direktes Messen am Quartz ist problematisch.

  • Hallo Nick,


    so sollte es sein. Mit PA bias max kann man die Ausgangsleistung in CW einstellen. Dies funktioniert bei mir nicht. Bei der Fehlersuche habe ich festgestelt, dass ich auf 40m 5W Ausgangsleistung erreiche, wenn ich die Gate der BS170 direkt mit dem 74ACT00 verbinde. Diese "Notlösung" bleibt bis nach dem OQRP-Contest. Falls du Zeit und die Möglichkeit hat, kannst du mir bitte die Spannung der Frequenz am Pin DRIVE bei 2 und 4W messen.

    Danke

  • DF5SF:

    bei Pout 2W am Pin "Drive" ca. 1,35 Vdc . Wert des Menu 8.3 - 49.

    Bei Pout 3,8W (hier Maximum) ca. 2,8 Vdc. Menu 8.3 - 140. Kann bis zu 4,3 Vdc steigen beim Wert 255, bringt aber keinen Zuwachs an Pout.

    Freq 7 MHz. HF-Amplitude ca. 6 Vss in beiden Fällen (mit Osci gemessen)

  • Hallo Nick,


    Danke für die schnelle Antwort.
    Habe damals gemessen: Amplitude immer ca. 4,5Vss.

    Unabhängig von der Einstellung des PA Bias max (Menu 8.3) war es immer ca. 2,2 Vdc (~1W). Anfang Januar wird weiter geforscht (HI).

  • Hallo,


    nachdem bei uns heute richtiges Bastelwetter ist, habe ich mir nochmals den uSDX vorgenommen. Die Ursache lag an den Endstufentransistoren BS170.

    Habe ca 20 Stck. BS170 aus einer mir unbekannten Quelle.

    Alle FETs ausgebaut und getestet. Ergebnis: Ein FET nicht identifizierbar (unknown or damaged), einer hatte eine Gate Threshold Voltage von 2,5V und der dritte von 3,7V.

    Dies liegt eindeutig ausserhalb der Spezifikation.

    Dann habe ich 3x B170 nach gleicher Gate Threshold Voltage (2.4V) selektiert und auf Stecksockel(!) eingebaut.

    Und siehe da: Die Ausgangsleistung lässt sich jetzt von ca. 0,4W (PA Bias max =25) bis über 6W (PA Bias max = 128) einstellen. Bei 6W erreiche ich einen Wirkungsgrad von ca. 80%.


    Merke: Halbleiter (unbekannter Herkunft) vor Einbau ausmessen. Dies kann Ärger ersparen.


    BLEIBT GESUND !!

  • Moin Uli,


    sehr schön, Glückwunsch! 6W Pout sind ja bald keine QRP mehr... :)) .

    Mit meinen 3,8 W bin ich noch nicht fertig.

    Ich werde die BS170 auch mal testen/selektieren. Das ist doch passende Gelegentheit den Kennlinientester (@ DL4JAL) mal entstauben. :)

    Zur Zeit kämpfe ich mit dem Abgleich/Kalibrierung PWR-Meter und 0-dBm-Quelle (beide @ DL4JAL). Nachher kann ich meine Pout mW-genau ausmessen! ;)

    Zwischendurch weitere QSO's mit dem uSDX geloggt - paar W's und PY auf 20m, UN und UA9 auf 40m. Alle in CW.

    Ich bekomme ein Eindruck dass die DSP bei dem Gerät für SSB optimiert ist. Auch beim 200 Hz-Filter höre ich noch starke Stationen die über 1 kHz höher/tiefer stehen. Erwarte ich zu viel von dem "Zwerg"? Frage an QCX-Besitzer: War es bei dem QCX auch so?