K2 : welcher Adapter RS232/USB mit WIN10 ?

  • Hallo Tom,


    der freundliche Chinese schickt ein Ersatzkabel.

    Deinen Vorschlag die Übertragungsrate zu reduzieren hatte ich auch versucht. Allein, die Baudrate ist im TRX fest programmiert. Wenn die Bits nicht schnell genug kommen, will er sie nicht haben.


    Hajo

  • DJ8LD: ich habe bei mir nachgesehen und finde die errormsg (...HXA no support) nicht mehr. Bei dem USB-Ser Kabel Treiber wurde am 8.6.20 via MS ein Treiber installiert, das war mit dem großen auto-update von Win10 1904 (Umstieg von Win7 im Febr.) auf 2004. Am 17.9. wurde updated, jetzt ist Prolific 3.8.37.0 vom 20.7.2020 als Treiber aktiv (war ein automatischer MS Driverupdate, nicht von mir angestoßen,USB-Kabel ist ständig gesteckt und auf COM2 gesetzt).


    Ich habe zwar das Kabel gesteckt, aber mein serieller (Museums-)Kram hat komplett Win16 S/W, d.h. mit Win10 noch nicht getestet. Da ich von den meisten 16bit Programmen die Basic-Source habe, will ich die neu kompilieren. Ich habe mir FreeBasic 1.05 downloaded, muß noch testen. Die alte S/W ist IBM-Basic oder QB4.50. Auf Visual mag ich nicht.


    Etwas OT, aber zumindest ist die Fehlermeldung nicht mehr auffindbar. Zum Verschwinden der COMs, bitte beim Device-Manager das Häkchen bei "hidden devices" nicht vergessen. Evtl. sind die nur "versteckt".


    73 Peter


    ps ich kann nicht feststellen, ob und mit welcher KB..... Kennung oder wie auch immer von MS der update lief. Evtl. nur Kabel stecken und eine Update requesten ??

  • auch auf der Driver Site von Prolific steht, dass der PL2303HXA nicht mehr unterstützt wird, also ist da wohl nichts mehr zu wollen - ausser auf Linux umzusteigen, aber das ist ja bekanntlich ein Thema für sich

  • Hallo Pascal, ich phantasiere ja nicht und poste nicht irgendwas ohne check. Die Fehlermeldung hatte ich bisher auch und nach einem neuen Kabel bereits recherchiert. Also habe ich vermutlich auch diesen Chip in dem USB-Teil. Ich habe heute wegen der gestrigen Posts von DJ8LD erneut in meinem Win10 alles durchsucht. Die Meldung ist weg und seit einer Woche ein neuer Treiber von Profilic drin, mit MS Zertifikat. Lt. Device Manager ist alles ok, nix mehr wie vorher angemeckert. Der Update war am 17.9.2020 8:57, Win10 prof 64bit und seit 8.6. die Version 2004.


    Es ist mir wurscht, was auf der HTML-Seite steht, installiert wurde von MS und der Treiber von Profilic. Ich kann ihn leider nur im Moment nicht testen, die Schnittstelle wird aber als aktiv und betriebsbereit ausgewiesen.


    73 Peter


  • Peter, ich wollte dir da gar nichts unterstellen, sorry deswegen...

    das Problem, selbst wenn man es mit Klimmzügen temporär wieder fixen kann, wird möglicherweise beim nächsten Windows Update wieder von neuem aufpoppen, also bleibt es immer eine potentielle Quelle für Ärger; ob es da lohnt, immer wieder neue Workarounds zu suchen...?

  • Hallo Pascal, kein Problem, wir haben evtl. zweierlei Blickwinkel. Es macht keinen Sinn von MS, einen Update auf einen nicht supporteten Chip los zu lassen, d.h. die Meldung nur weg zu putzen. Das war ein offizieller Treiberupdate, mit einem July/2020 Datum und für die Version 2004. Die Seite von Prolific, die ich gefunden habe, hat Treiber von 2015. Ich habe mich Null um den Update bemüht, der kam von MS aus.


    Ich habe es nur nochmal so explizit gepostet, damit evtl. jemand mit dem Chip bzw. der bisherigen Meldung das mit dieser neuen Treiberversion gegenprüfen kann. D.h. ob er diese neue Treiberversion drin hat und ob damit das Kabel klappt. Ich habe leider (noch) keine S/W, um mein Kabel, welches mit XP noch funktionierte, erneut zu testen.


    Ich warte erst mal ab mit Neukauf und bringe mein Afu-Museum auf Win32-S/W. 73 Peter

  • jup, keine Ahnung, da kann ich nicht mitreden; die zwei Win10 Installationen (eine in einer qemu VM), die ich hab, laden einfach alles über Windows Update nach, was da so Neues rauskommt; ich hab mich da noch nicht gross drum gekümmert, was genau da reinkommt, weil es für mich sowieso low priority ist

    so wie ich es aber bisher verstanden hab, bügelt seit Win10 die Updatefunktion von selbst ständig neue Treiber über die alten, womit man auf längere Sicht einem mit dem HXA-Chip nicht kompatiblen Treiber gar nicht entgehen kann...


    das ist jetzt aber nur meine Annahme

  • Hallo,


    ja, die versteckten Ports hatte ich gefunden. Nur als ich die Treiber erneuern wollte, zogen es die Kabel vor, zu verschwinden.


    Aber noch zwei Fragen:

    Wird der USBstecker mit Chip warm/heiss? Zwei werden heiss, einer bleibt kalt.


    Ich habe von Elitma Virtuelle Serial Ports, die rechnerintern gut funktionieren. Nun habe ich entdeckt, dass man auch einen physikalischen Port generieren kann.

    Der wird im Gerätemanager als Kommunikationsanschluss (COM 1) angezeigt und von Terraterm auch erkannt mit den (kaputten) Kabeln. Weiter bin ich noch nicht gekommen, da ich den Port noch suche ;)


    Hajo

  • Nun habe ich entdeckt, dass man auch einen physikalischen Port generieren kann.

    Der wird im Gerätemanager als Kommunikationsanschluss (COM 1) angezeigt

    Windows hat eigentlich in jeder Installation einen COM1 im Gerätemanager stehen. Der wird intern von Windows verwendet



    73´s Jürgen , ALT-512 SDR 10 Wtts, mittlerweile 50m endgespeist an der Luft + TS-790E für VHF/UHF mit Indoor X-30 und

    4-Ele LPDA. Moxon für 6m/4m ebenfalls Indoor .... Xiegu G90 mit Eremit 18 AH LiFePO4 und 12m Spidermast für outdoor.

    Member Log4OM Alpha- & Betatest Team