Beiträge von OE1WKC

    Lieber Bert,


    ich habe den DDS Chip bereits getauscht und zwischenzeitlich die gesamte Platine mit Heißluft entlötet und neu bestückt - Problem besteht weiterhin und ich werde langsam ratlos ...


    73 de wolfgang, OE1WKC

    Danke Uwe für den Hinweis zum Thema USB Spannungsversorgung. Folgendes habe ich zwischenzeitlich gemacht:


    Baustelle 1 - DDS Modul

    • AD9834 getauscht (wie Peter DK7IH vorgeschlagen), allerdings keine merkliche Veränderung
    • Versorgungsspannung und Ansteuerung des DDS Modul vom HOBO, allerdings Platine über kurze Drahbrücken verbunden um Ausgangssignal direkt am DDS Modul Ausgang aufzunehmen

    Das ungefilterte Ausgangssignals des DDS Chips hat (wie bei der DDS Synthese zu erwarten) viele Frequenzkomponenten (diesmal Foto statt Screenshot, da am Screenshot die Obertöne nicht so deutlich sichtbar sind).


    Die Grundschwingung bei 16MHz ist im Spektrum (entspricht 40m Band ZF) aber zu erkennen


    Wenn ich die Zeitbasis um den Faktor 20 verlängere sieht man deutlich eine Modulation


    Jetzt wäre es interessant, ob das das typische, ungefilterte Rohsignal des AD9834 ist, oder hier doch ein Problem im Aufbau des DDS Modul besteht. Wie schon erwähnt wäre ein Vergleichsbild hilfreich.


    Baustelle 2: SSB Modul

    • Ersatz Dual Mosfet BF982 eingetroffen und eingebaut, aber nach wie vor kein Signal an Drain!?
    • ca. 500mVss (dreiecksförmig) an PIN6 SA612
    • ca. 800mVss (Sinus) an C7 (vor dem Quarzfilter)
    • ca. 700mVss (Sinus) an Gate 1 (nach dem Filter)
    • kein verwertbares Signal an Drain (die Werte aller Bauelemente nach Drain kontrolliert, Trafo Tr1 neu gewickelt und beidseitig auf Durchgang geprüft)
    • ca. 4V an Gate 2
    • Je nach Sendeleistungseinstellung (Pot) 1,0 - 0,1 V an Source

    73 de wolfgang, OE1WKC

    Ich habe mich jetzt mal länger mit dem AD9834 DDS beschäftigt. Mittels eines kleinen Programms ARDUINO TESTCODE FOR AD9833 Micro Waveform Generator habe ich die HOBO DDS Platine mit einem Referenzdesign (allerdings mit integriertem Filter) bei 12 MHz getestet.



    Der Pegel beim HOBO DDS Modul schwankt um ca. 70 mV.

    Ist jemanden schon so ein Verhalten bei einem DDS Chip untergekommen und sollte ich den DDS Chip tauschen?


    73 de wolfgang, OE1WKC


    Lieber Manfred,


    ich habe das Problem jetzt mit Peters´s Hilfe vorerst eingegrenzt und konzentriere mich auf das DDS Modul - siehe mein letzter Beitrag.

    SSB Modul ist die nächste Baustelle wenn meine neuen BF982 er da sind.


    73

    wolfgang

    Peter,


    Versorgungsspannung des Labornetzgeräts ist sauber; habe testweise auch Akkubetrieb getestet - Schwingungen bleiben.

    Jetzt habe ich das DDS Modul ausgebaut und an St1/Pin2 einen Sinus mit rd. 400mVss des Signalsgenerators eingespeist - alle Schwingungen sind weg saubere Signale an 74HC04_Pin1/Pin2 mit 2 bzw. 6,4Vss.

    Nach nochmaliger Prüfung des DDS Moduls unter dem Mikroskop sind keine Auffälligkeiten erkennbar.


    Aktuell habe ich nur AD9850 Testprogramme bei meinen AVR´s. Werde mal die Ansteuerung des DDS Moduls mit AD9834 für standalone Test programmieren.

    Hast Du vielleicht ein Skope Bild des DDS Ausgangssignals - ohne Filter?


    73

    wolfgang

    Lieber Peter´s,

    ... ein sauberes Schaltsignal mit eindeutiger Frequenz erhalten.

    nein, leider nicht. Aufgrund der Schwingungen sind alle Oszillogramme (siehe auch PDF) mit 5 sek. Persistenz:


    1. DDS_Band_Bu1-6 - DDS Ausgangssignal Steckplatz Bandmodul
    2. Mischer_LO_In_Bridge - DDS Eingangssignal Bandmodul gebrückt (Bu1 6/8)
    3. Mischer_LO_In_Band - Bandmodul mit gebrücktem DDS NAchfilter (C5/C9 entfernt, R3 noch vorhanden)
    4. 74HC04_Pin1 - NAND Gatter Eingang (Analogverstärker)
    5. 74HC04_Pin2 - NAND Gatter Ausgang
    6. 74HC04_Pin2a - Messung Hub Frequenzmodulation ca. 2 MHz (13,7 zu 16MHz)

    ... prüfe mal die Beschaltung R7 R11 , der eine ist 22R der andere 220R . ..

    Lieber Manfred, danke für Deine vielen Hinweise. Auf´s erste habe ich keinen Bestückungsfehler gefunden. Allerdings vermute ich aufgrund der Maxima, dass mein Qurzfilter eine ähnliche Welligkeit hat wie in Deiner Doku. Wie hast Du das gelöst?


    73

    wolfgang

    Lieber Markus,


    Hallo Wolfgang,


    Da bekommst Du eine prima Vorlage für Deine Testschaltung, z.B. Philips Datenblatt BF981.

    danke für den Hinweis. Hatte bis jetzt immer nur die Kurzversion des BF981 Datenblattes gefunden. Aufgrund Deines Hinweises habe ich weiter recherchiert und nun das vollständuge Datenblatt inklusive Testschaltung gefunden. Habe meinen Lochrasteraufbau nochmals überprüft und korregiert; jetzt funktioniert der Testaufbau (Peter: 8Veff war ein Meßfehler).


    Bei 9MHz/1Vss Input aus Signalsgenerator an G2 des BF981 der Lochrasterschaltung erhalte ich jetzt am Drain eine maximale Amplitude von ca. 800mVss die ich mit einer Steuerspannung von 0,2Veff bis 1Veff an G1 um ca. 10dB reduzieren kann (max. Output an Drain bei 0,2Veff Steuerspannung). Peter: die Ablockkondensatoren sind auf der Unterseite da 47n Kerkos bei mir aktuell aus sind und ich SMD verwende.


    Ich bin von einem vollständige falschen Konzept ausgegangen und war immmer der Meinung, dass der DGM eine hohe Verstärkung liefert. Dank Peter II Hinweis verstehe ich ich nun dieses Schaltungsdetail und traue wieder meinen DGM´s.


    Jetzt nehme ich mir den Schaltmischer vor.


    73 wolfgang