Hobo Endstufe schwingt

  • Lieber Peter´s,

    ... ein sauberes Schaltsignal mit eindeutiger Frequenz erhalten.

    nein, leider nicht. Aufgrund der Schwingungen sind alle Oszillogramme (siehe auch PDF) mit 5 sek. Persistenz:


    1. DDS_Band_Bu1-6 - DDS Ausgangssignal Steckplatz Bandmodul
    2. Mischer_LO_In_Bridge - DDS Eingangssignal Bandmodul gebrückt (Bu1 6/8)
    3. Mischer_LO_In_Band - Bandmodul mit gebrücktem DDS NAchfilter (C5/C9 entfernt, R3 noch vorhanden)
    4. 74HC04_Pin1 - NAND Gatter Eingang (Analogverstärker)
    5. 74HC04_Pin2 - NAND Gatter Ausgang
    6. 74HC04_Pin2a - Messung Hub Frequenzmodulation ca. 2 MHz (13,7 zu 16MHz)

    ... prüfe mal die Beschaltung R7 R11 , der eine ist 22R der andere 220R . ..

    Lieber Manfred, danke für Deine vielen Hinweise. Auf´s erste habe ich keinen Bestückungsfehler gefunden. Allerdings vermute ich aufgrund der Maxima, dass mein Qurzfilter eine ähnliche Welligkeit hat wie in Deiner Doku. Wie hast Du das gelöst?


    73

    wolfgang

  • Wolfgang,

    wir tun uns etwas schwer mit deinen Skope Bildern. Was heißt Quelle Mathe?

    Ich habe mal in meinem Archiv gegraben und die Schirmbilder an IC2 herausgesucht, wie ich sie damals beim Prototyp gemessen habe. Irgendwie scheinen bei dir ja alle Signale vom DDS bis zum Mischerausgang mit einer Schwingung überlagert zu sein. Ist den wenigstens die Versorgungsspannung sauber?

    73/2 de Peter, DL2FI
    Proud member of Second Class Operators Club SOC and Flying Pig Zapper #OOO (Certificated Kit Destroyer)

  • Peter,


    Versorgungsspannung des Labornetzgeräts ist sauber; habe testweise auch Akkubetrieb getestet - Schwingungen bleiben.

    Jetzt habe ich das DDS Modul ausgebaut und an St1/Pin2 einen Sinus mit rd. 400mVss des Signalsgenerators eingespeist - alle Schwingungen sind weg saubere Signale an 74HC04_Pin1/Pin2 mit 2 bzw. 6,4Vss.

    Nach nochmaliger Prüfung des DDS Moduls unter dem Mikroskop sind keine Auffälligkeiten erkennbar.


    Aktuell habe ich nur AD9850 Testprogramme bei meinen AVR´s. Werde mal die Ansteuerung des DDS Moduls mit AD9834 für standalone Test programmieren.

    Hast Du vielleicht ein Skope Bild des DDS Ausgangssignals - ohne Filter?


    73

    wolfgang

    -------------------------------------

    73 de wolfgang, OE1WKC

  • Hast Du vielleicht ein Skope Bild des DDS Ausgangssignals - ohne Filter?

    Leider nicht gefunden, vielleicht kann einer der vielen Hobo Nutzer mal ein Bild schicken.

    73/2 de Peter, DL2FI
    Proud member of Second Class Operators Club SOC and Flying Pig Zapper #OOO (Certificated Kit Destroyer)

  • Hallo Wolfgang,

    mal so ein Gedanke , ohne in die Schaltung zu sehen und die Bauteile zu benennen. Die Modulatorbaugruppe wird mit einem 9MHz Signal

    an Pin6 mit 250 bis 300mV HF eingespeist . Der Mischer ist ein NE602 oder baugleicher Typ. Wenn HF eingespeist wird kommt am Ausgang

    nichts raus , so sollte es sein . Durch NF an den Pins 1 und 2 bringe ich den Modulator aus der Balance und erhalte am Ausgang ein Mischsignal.

    Bei cw wird ein Pin von 1 oder 2 nach Masse gezogen , so dass auch wieder Signal am Ausgang ankommt . Diese Steuerfunktion ist aber nicht

    abrupt , sondern ist gleitend . Was kann nun die Welligkeit hervorrufen, das Signal 9MHz zum Pin 6 ist moduliert , oder es kommt von ungewollten

    Signalen an den Pins 1 oder 2 . Weiter könnte es noch her kommen , wenn nach dem Quarzfilter eine Reflektion wegen Fehlanpassung auftritt.

    Mal das Signal an Pin 6 analysieren. Weiter Pin 1 und 2 freischalten und nur mit einem Widerstand von 2 bis 3 K mit einander verbinden , jetzt sollte

    bei Sgnal am Pin 6 , am Ausgang kein Signal vorhanden sein, bei symetrischer Belastung des Ausganges.

    Irgendwo muss doch das " Störsignal " herkommen.

    73 de

  • Lieber Manfred,


    ich habe das Problem jetzt mit Peters´s Hilfe vorerst eingegrenzt und konzentriere mich auf das DDS Modul - siehe mein letzter Beitrag.

    SSB Modul ist die nächste Baustelle wenn meine neuen BF982 er da sind.


    73

    wolfgang

    -------------------------------------

    73 de wolfgang, OE1WKC

  • Hallo Wolfgang,


    vielleicht hast schon entsprechend geprüft- ich weiss, dass das Motherboard des HOBO und auch einige Stellen auf den Modulen gerade an den Massestellen problematisch sein können. Ist dort (oder vielleicht an mehreren Stellen) was "kalt" dann gerät sehr schnell was aus dem Ruder. Ich empfehle so aus der Ferne die Lötstellen gerade auf den Modulen und noch wichtiger die Verbindungen über die Stifte/Buchsen kritisch zu prüfen.

    Ich schreibe das, weil ich an mancher Stelle mir nen Wolf gesucht habe und dann war es so eine Schludrigkeit...

    Nichts für Ungut... und Erfolg wünscht


    Andy

    DK3JI

  • Ich habe mich jetzt mal länger mit dem AD9834 DDS beschäftigt. Mittels eines kleinen Programms ARDUINO TESTCODE FOR AD9833 Micro Waveform Generator habe ich die HOBO DDS Platine mit einem Referenzdesign (allerdings mit integriertem Filter) bei 12 MHz getestet.



    Der Pegel beim HOBO DDS Modul schwankt um ca. 70 mV.

    Ist jemanden schon so ein Verhalten bei einem DDS Chip untergekommen und sollte ich den DDS Chip tauschen?


    73 de wolfgang, OE1WKC

    -------------------------------------

    73 de wolfgang, OE1WKC

  • Hallo Uwe,


    der Amplitudenschwankungsbereich (durch die beiden Striche markiert) ist ca. 35mV pro Halbwelle.


    -------------------------------------

    73 de wolfgang, OE1WKC