Xnec2c - Problem - unter Linux.

  • Danke Markus,


    für den Hinweis. Ich werde das Programm bei Gelegenheit installieren.


    73 de Hajo

  • Hallo Hajo,
    hallo OMs,


    Beschreibung zum Programm findest Du/Ihr unter:


    http://www.qsl.net/5b4az/pkg/nec2/xnec2c/doc/xnec2c.html


    Herunterladen kann man es unter:


    http://www.qsl.net/5b4az/


    genauer unter


    http://www.qsl.net/5b4az/pages…xnec2c/xnec2c-3.4.tar.bz2 (mit GTK2 GUI)


    http://www.qsl.net/5b4az/pages…2/nec2c/nec2c-1.3.tar.bz2 (ohne GUI)
    wenn man einen Output als File braucht. (z.B. für das Power Budget) um die Ergebnisse auf Plausibilität zu überprüfen.



    Software entpacken


    tar -jxvf nec2c-1.3.tar.bz2


    und/oder


    tar -jxvf xnec2c-3.4.tar.bz2


    ins Verzeichnis wechseln und jeweils autogen.sh aufrufen


    Bei meinem OS (OpenSuse 13.1 x86_64)


    musste ich noch das Packet intltool nachinstallieren.


    sudo zypper install intltool



    danach


    make


    und


    make inatall (als root oder via sudo)


    danach sollte es z.B. unter /usr/local/bin die beiden Programme


    nec2c


    und


    xnec2c


    geben.



    Viel Spaß beim Simmulieren von Antennen und Leitungen.


    Gruß
    Markus


    PS.: in dem Artikel auf http://www.mikrocontroller.net/topic/375322#4252056 findet Ihr einige Code-Modifikationen,
    die den Fehler mit dem 80 Zeichen langen Filenamen mit Pfad Limit beheben.


    shared.h:extern char infile[81]; durch extern char infile[PATH_MAX+1];
    shared.c:char infile[81] = ""; durch char infile[PATH_MAX+1]= "";
    fork.c:retval = Read_Pipe( num_child, infile, 80, FALSE ); durch retval = Read_Pipe( num_child, infile,PATH_MAX , FALSE );



    limits.h in alle drei genannten Files includieren!


    #include <limits.h> /* to overcome 80 character infile name length limitation */

  • Moin,


    das ist doch bei Debian / Ubuntu im Packet-Management enthalten ...


    73, Tom

    Ich bin dann mal weg ...

  • Hallo Tom,


    da nicht jeder Debian Ableger verwendet, ist es mir auch nicht klar gewesen.


    Ich habe noch eine Kleine Modifikation am Code vorgenommen, um das Step-Fenster auf vier Stellen
    zu erweitern, um größere Frequenzbereiche duchlaufen zu können.


    Betrifft die NEC Parameter 'FR'


    Ist nur reine Kosmetik, da richtig gerechnet wird aber die Anzeige nur dreistellig ist.


    Durchgeführte Modifikationen:



    interface.c Zeile 355


    gtk_entry_set_max_length (GTK_ENTRY (structure_fstep_entry), 4); /* 3 -> 4 */


    interface.c Zeile 359


    gtk_entry_set_width_chars (GTK_ENTRY (structure_fstep_entry), 4); /* 3 -> 4 */



    utils.c: 297 - 299



    /* Display_Fstep()
    *
    * Displays the current frequency step number
    */
    void
    Display_Fstep( GtkEntry *entry, int fstep )
    {
    char str[5]; /* 4 -> 5 */


    snprintf( str, sizeof(str), "%4d", fstep ); /* 3 -> 4 */
    gtk_entry_set_text( entry, str );
    }



    Gruß
    Markus