Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Forum der DL-QRP-AG für QRP und Selbstbau im Amateurfunk. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 22. April 2010, 12:19

Harzburg, neue DLL zum Download

73/2 de Peter, DL2FI
Don´t follow the path. Make one! (Helena Martins, Fotografin, die im Erwachsenenalter ihr Gehör verlor)

2

Mittwoch, 14. Juli 2010, 11:47

Probleme mit neuer DLL 0.6.3.0

Hallo,

bei mir führt die neue DLL 0.6.3.0 auf einem Lenovo S10e Netbook mit Windows XP zum Absturz (einfrieren) von WinradHD. WinradHD lässt sich zunächst starten, ein Verschieben des Empfangsfrequenz in der Spektrumdarstellung mit der Maus hat Zugriffsverletzungen im Modul "Extio_HarzburgRadioDLL" auf der Adresse 01DC1B6B bei Schreiben der Adresse 0000001 zur Folge.
Die DLL 0.5.1.1 funktioniert problemlos.

73 de Lutz, DK3WI

Ansonsten bin ich mit dem SDR-Rx sehr zufrieden!

3

Mittwoch, 14. Juli 2010, 15:30

Hallo,

bei mir führt die neue DLL 0.6.3.0 auf einem Lenovo S10e Netbook mit Windows XP zum Absturz (einfrieren) von WinradHD. WinradHD lässt sich zunächst starten, ein Verschieben des Empfangsfrequenz in der Spektrumdarstellung mit der Maus hat Zugriffsverletzungen im Modul "Extio_HarzburgRadioDLL" auf der Adresse 01DC1B6B bei Schreiben der Adresse 0000001 zur Folge.
Die DLL 0.5.1.1 funktioniert problemlos.

73 de Lutz, DK3WI

Ansonsten bin ich mit dem SDR-Rx sehr zufrieden!


Lutz, da seit April alle neuen Harzburg mit der neuen DLL ausgeliefert wurden und auf X verschiedenen Rechnern laufen, kann das nur an deiner Konfiguration liegen.

Wichig ist, dass du vor dem ersten Start die Harzburg Ini löscht!! Das programm schreibt sich die passende Ini dann selbst.
73/2 de Peter, DL2FI
Don´t follow the path. Make one! (Helena Martins, Fotografin, die im Erwachsenenalter ihr Gehör verlor)

4

Donnerstag, 15. Juli 2010, 10:49

Lutz, da seit April alle neuen Harzburg mit der neuen DLL ausgeliefert wurden und auf X verschiedenen Rechnern laufen, kann das nur an deiner Konfiguration liegen.
Wichig ist, dass du vor dem ersten Start die Harzburg Ini löscht!! Das programm schreibt sich die passende Ini dann selbst.


Peter, Danke für die Anwort.
Die Situation ist aber so, wie von mir beschrieben.

Auf einem anderen (Desktop-)Rechner - auch mit USB-Seriellen-Adapter und Windows XP - funktioniert WinradHD in der Version 0.18 vom 25.06.2010 mit der Harzburg-DLL 0.6.3.0 vom 21.4.2010 problemlos.

Auf dem Netbook Lenovo S10e und Windows XP stürzt WinradHD 0.18 mit der DLL 0.6.3.0 ab (access violation in der Harzburg-dll). Man kann die DLL und Winrad dann nur noch im Taskmanager "abschießen".

OK - liegt die Schlußfolgerung nahe, die Konfiguration ist fehlerhaft. Aber: mit der alten DLL 0.5.1.1 gibt es keine Probleme (die ini-Datei selbstverständlich immer gelöscht). Habe ich mehrmals probiert, Situation bleibt die gleiche.
Da würde ich doch den leisen Verdacht hegen, daß möglicherweise die neue DLL weniger verträglich mit allen möglichen Konfigurationen ist.

Ich erwarte keine Lösung, wollte aber auf "mein" Problem aufmerksam machen.

73 de Lutz, DK3WI

http://www.mydarc.de/dk3wi/html/sdr-rx_harzburg.html

5

Donnerstag, 15. Juli 2010, 11:26

Ok, wenn es bei dir auf einem anderen Rechner läuft, dann ist das schon mal gut.
Ich kenne diese Schutzrechnung im Zusammenhang mit einem COM Port Problem. Wenn die INI gelöscht ist, versucht die DLL zuerst die COM Port Erkennung. Sie zeigt die gefundenen Ports an, und versucht im zweiten Schritt das Harzburg zu erkennen.

Laüft das auf dem Lenovo richtig ab? Wird Harzburg erkannt??
73/2 de Peter, DL2FI
Don´t follow the path. Make one! (Helena Martins, Fotografin, die im Erwachsenenalter ihr Gehör verlor)

  • »DK1RM« ist männlich

Beiträge: 521

Hobbys: Basteln, löten, ungewöhnliche Ideen

  • Nachricht senden

6

Donnerstag, 15. Juli 2010, 13:07

Moin zusammen.

IBM verbaut im "preisgünstigen Segment" (->Lenovo) gerne mal abgespeckte Chipsätze. Diese Chips werden von der Hardwareerkennung als "Originale" erkannt, verhalten sich jedoch u.U. "ein klein wenig anders". Das war schon bei den älteren "Thinkpad"-Notebooks so. Ich denke, auch das könnte die Ursache für die beschriebenen Probleme sein.

73 de Roland / DK1RM

7

Donnerstag, 15. Juli 2010, 16:09

Hallo Peter & Roland,

die Com-Port-Erkennung läuft bei beiden DLLs problemlos, auch der Harzburg wird erkannt.

Nochmal:
Mein Problem ist nicht, dass auf dem Lenovo WinradHD mit der Harzburg-DLL nicht läuft, sondern dass die alte DLL 0.5.1.1 funktioniert, die neue 0.6.3.0 aber nicht. Dieser Fehler auf meinem spezifischen Rechner ist reproduzierbar, das Programm funktioniert zunächst, stürzt aber z.B. ab, wenn mit der (USB-)Maus in der Spektrumdarstellung die Frequenz verschoben wird.

Mit besten Grüßen an die Harzburggemeinde

Lutz, DK3WI

  • »DH8DAP« ist männlich

Beiträge: 753

Hobbys: QRP, Ausbildung, Jugendarbeit

  • Nachricht senden

8

Donnerstag, 15. Juli 2010, 17:35

Hallo Lutz,

könnte das evtl. ein Problem der Gesamt-Prozessor-Belastung sein? (siehe links unten im WinradHD-Fenster)

Ich hatte das Problem anfangs auch (siehe http://www.qrpforum.de/index.php?page=Th…D=5244&pageNo=2 in meinem ersten Posting der erste Punkt und Lösungen im weiteren Thread).
Auf dem Laptop war es sogar extrem. Wenn ich dort den WLAN-TRX abschalte läuft alles und die Prozessor-Belastung geht extrem zurück.
vy 72 de DH8DAP, Frank aus Schwelm nr Wuppertal, JO31PG
www.golf19.de

9

Freitag, 16. Juli 2010, 11:13

Hallo Frank,

Danke für den Tipp, aber die Gesamtprozessorbelastung liegt zwischen 25 und max. 55 %, daran kann es also auch nicht liegen (würde auch nicht erklären, warum die alte DLL funktioniert, die neue aber Schwierigkeiten macht).

Für mich ist das Problem momentan ohne Bedeutung (der Lenovo funftioniert mit der alten DLL, der eigentliche "Afu-"Rechner auch mit der neuen).
Vielleicht liest der Autor der DLL (Robert) hier mit und kann mit dem Problem etwas anfangen.

73 de Lutz, DK3WI

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »DK3WI« (16. Juli 2010, 16:06)


10

Dienstag, 10. August 2010, 09:56

Neue DLL für Harzburg Solo und Harzburg mit Sodira

Ich habe gerade die neuesten DLLs hochgeladen.
DLL für Harzburg Radio zum Betrieb mit WinradHD
DLL für Betrieb des Harzburg Radios mit der SODIRA Software (DRM Empfang)

Wer SODIRA nocht nicht installiert hat, der sollte sich vorher aber die Installationstipps durchlesen.
73/2 de Peter, DL2FI
Don´t follow the path. Make one! (Helena Martins, Fotografin, die im Erwachsenenalter ihr Gehör verlor)