Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Forum der DL-QRP-AG für QRP und Selbstbau im Amateurfunk. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Freitag, 16. Oktober 2009, 10:29

Birdies, Pfeifstellen, Mischer-Problem

Unter bestimmten Umständen kann es vorkommen, dass sich auf der Hobo Mischerplatine eine niederfrequente Schwingung auf der 5 Volt Leitung aufbaut. Ursache ist mit ziemlicher Sicherheit ein Resonanzkreis der aus der Versorgungsdrossel DR1 und den Abblockkondensatoren in Zusammenarbeit mit der Mischeranpassung T1 gebildet wird. Abhilfe schafft ein 22uF Elko oder 22uF Tantal parallel zu einem der Abblock Kondensatoren. Dadurch wird die Güte des Kreises soweit herab gesetzt, dass keine Schwungungen mehr entstehen können. Grundsätzlich könnte eine Änderung der Drosselwerte / des Typs zur Beseitigung des Fehlers führen, wir halten aber den nachträglichen Einbau des Elkos für den einfacheren Weg.

Zur Geschichte,
Dirk, DK2DH berichtete hier im Forum von dem Problem und seiner Lösung. Werner, DC6NE berichtete mir direkt per Telefon, dass er das gleiche Problem hatte und Dirks Lösung auch bei ihm funktionierte. Wenn das gleiche Problem schon an zwei Stellen auftritt, dann untersuchen wir das Problem natürlich. Ihr seht also, wie wichtig es ist, auftretende Probleme und Lösungsvorschläge zur Diskussion zu stellen.

Hier noch einmal der Original Text von Dirk:

Zitat


Problem #1: Der Empfänger lieferte anfangs nur sehr schwache Signale, dafür aber jede Menge Pfeifstellen und Geistersignale. Eine Änderung der Frequenz hatte irgendwie nicht wirklich Einfluss auf die empfangen Signale. Erster Verdacht: Das Signal hinter dem DDS-Nachfilter ist zu schwach... Eine Kontrollmessung mittels 10:1-Tastkopf zeigte, dass das DDS-Signal zwar wie gewünscht vorhanden war, aber von einem sehr großen NF-Signal (Frequenz ca. 40kHz) überlagert wurde. Auch am DDS-Nachverstärker auf dem Mischermodul war dieser Effekt zu beobachten. Der Vorverstärker wurde in den Maxima des NF-Signals so weit übersteuert, dass das DDS-Signal immer wieder für mehrere µs durch 5V-DC-Passagen ersetzt wurde. Hierdurch konnten die Mischer logischerweise nicht optimal funktionieren. Die Quelle des Übels wurde auf der Mischerplatine lokalisiert. Die 5V-Spannungsversorgung der Mischerplatine wird vom Mainboard mittels einer 47µH-Drossel abgekoppelt. Auf dem Mainboard war die Spannung in Ordnung. Hinter der Drossel lag auf der 5V-Gleichspannung eine Wechselspannung mit ca. 1Vss mit der bekannten Frequenz von ca. 40kHz. Eine 22µF-Elko parallel zu C4 (auf dem Mischermodul) machte dem Spuk ein Ende.
73/2 de Peter, DL2FI
Don´t follow the path. Make one! (Helena Martins, Fotografin, die im Erwachsenenalter ihr Gehör verlor)

2

Dienstag, 5. Januar 2010, 16:21

RE: Birdies, Pfeifstellen, Mischer-Problem

Hallo,

nach einer SEHR langen Pause bin ich nun über die Feiertage endlich mal wieder dazu gekommen am HOBO wieder weiterzubauen.
Prompt trat bei mir das beschriebene Problem auf.
Pfeifstellen ohne Ende, der Empfänger schien mir etwas taub ...
Dank dem Forum ein erster Lösungsansatz, Elko eigelötet.
Das brachte aber noch nicht den gewünschten Erfolg. Nun wurde doch intensiver genessen. Trotz 22uF ist auf den 5V ein nicht unerhebliches "niederfrequentes" Störsignal. Das hat zur Folge dass das (doch recht kleine) DDS Signal nicht sauber hinter dem ersten Inverter herauskommt.
Für mich sieht es danach aus, dass der 74HC04 schwingt.
Mit dem 1MOhm wird der Inverter wohl in einen "linearen " Arbeitsbereich verschoben. Und genau da werden wohl recht hohe Impulsströne gezogen, was man auf der 5V Strecke sehen kann.

Liege ich mit meinen Annahmen da richtig?

Wie gesagt, der 22uF Tantal-Elko reicht bei mir wohl nicht aus. Was kann ich weiter tun?

Danke und Gruss
Dirk

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »DL7VDC« (5. Januar 2010, 16:22)


  • »DM3DA« ist männlich

Beiträge: 1 006

Hobbys: Selbstbau, Contest, 4m, K2, Morse-Hörspiel

  • Nachricht senden

3

Dienstag, 5. Januar 2010, 16:38

RE: Birdies, Pfeifstellen, Mischer-Problem

Hallo Dirk,

wenn ich Dich richtig verstehe, hast einen der Abblockkondensatoren durch einen 22uF Tantal-Elko ersetzt. Gemeint ist aber, den Tantal-Kondensator zusätzlich zum Abblockkondensator parallel einzubauen. Also C4 und parallel dazu der Tantal. Hast Du das mal probiert?

73 Daniel DM3DA
Daniel DM3DA, Düsseldorf JO31jf, DOK R01 +++ Morse-Hörspiele auf http://dm3da.tuxomania.net

  • »HB9DKW« ist männlich

Beiträge: 39

Hobbys: PSK31, SDR,CW, Simulation, Arduino, Klettern

  • Nachricht senden

4

Dienstag, 5. Januar 2010, 22:24

Hallo zusammen
bei mir tauchte bei SDR-Einsteiger Kit vom FA ein ähnliches Probem auf. Das Ding produzierte wilde Schwingungen auf der 5V Versorgung des Mischers. Und das abhängig von der Länge des Stromversorgungskabels. Da mein Verdacht auf den 5 V Regler viel hab ich einfach mal das Ding (Type ET 78L05) gegen einen National 340LAZ-05 (war zufällig vorhanden) ausgetauscht. Und weg waren die Schwingungen. Warum der Regler diesen Mist produzierte ist nicht klar, seine Herkunft allerdings auch nicht. Es könnte auch eine Fälschung sein. Der Neue stammt von einem sehr zuverlässigen Lieferanten
(Distrelec).

vy 73 HB9DKW Robert
Der Strom hat immer recht!!!!!

5

Mittwoch, 6. Januar 2010, 07:49

Hallo Daniel,

den 22uF Elko hatte ich wie im Forum beschrieben parallel zu C4 gelötet. Das reicht (zumindest bei mir) nicht.
@ Robert: An den 5V Regler hatte ich auch schon gedacht. Aber der ist für die Schwingung nicht verantwortlich. Ich hatte die Mischerplatine direkt aus dem Netzteil mit 5V versorgt. Dennoch war die Schwingung zu sehen. Ohne Veränderung.
Als nächstes werde ich mal versuchen, den Widerstand über dem Inverter zu verändern. Wenn ich damit wenigstens die Frequenz der Störung verändere, dann weiss ich wenigstens die Quelle der Schwingung.
Oder hat noch jemand eine Idee?

Allzuviel Platz ist ja nicht auf der Mischerplatine. Also versuche ich erst einmal mit Umdimensionierung auszukommen.

Gruss, Dirk

6

Mittwoch, 6. Januar 2010, 10:43

Zitat

Original von DL7VDC

Als nächstes werde ich mal versuchen, den Widerstand über dem Inverter zu verändern.

Gruss, Dirk


Hallo Dirk,

das würde ich nicht machen. Dieses Verfahren der Signalformung setzen wir ja auch schon bei anderen Transceivern erfolgreich ein, es ist eigentlich eine Standard Schaltung. Das problem hat mit ziemlicher Sicherheit eine andere Ursache.

Nach deiner Beschreibung sieht es mit ziemlicher Sicherheit so aus, daß am DDS- Nachfilter zu wenig Pegel herauskommt. Rückgekoppelte Gatter haben die Eigenschaft unterhalb einer HF- Mindestspannung am Eingang (~ 100mVss) zu schwingen da sie eine hohe Leerlaufverstärkung aufweisen. Den gleichen Effekt kann man auch bei Frequenzzählern beobachten wo die Vorteiler ohne Nutzsignal wild oszillieren.
Überbrück als erstes mal dein DDS Nachfilter und schau was dann passiert.
Ist es damit ok, musst du den Bandpass untersuchen. Im Grunde genommen ist er eigentlich fast überflüssig, an dieser Stelle wollten wir vielleicht etwas zu gut sein. Wir wissen aber inzwischen, dass die Drosseln in der Regel eine deutliche Tendenz zu niedrigeren Werten haben, so dass die Bandpässe häufig viel zu hoch liegen.

Eventuell bringt auch eine drastische Verkleinerung oder Vergrößerung des Koppel-Cs zum Gatter- Eingang Erfolg- die bessere Lösung ist aber die Suche nach den verloren gegangenen mV's beim DDS.
73/2 de Peter, DL2FI
Don´t follow the path. Make one! (Helena Martins, Fotografin, die im Erwachsenenalter ihr Gehör verlor)

7

Donnerstag, 7. Januar 2010, 09:50

hallo,

gestern bin ich nur noch ein wenig zum messen gekommen.
Wenn ich das DDS-Filter nicht verwende, dann sieht es so aus, als ob der Mischer ein korrektes Sigmal bekommt.

In einem anderen Thred wurde schon einmal die Frage gestellt, ob es denn richtig ist, dass das Filter eine so hohe Dämpfung von 20dB hat. Dazu kam keine Antwort. Zumindest habe ich keine gefunden. Ich habe auch mal mit dem NWT gemessen und die gleiche Dämpfung ermittelt. Ubrigens mit 1:9 Transformation sowohl am Eingang als auch am Ausgang abgeschlossen.
Zugegeben 1:4 wäre richtig, hatte ich aber gerade nicht da.
Dennoch, 20dB sind "immer" zu messen, auch mit abgeschlossenen 50Ohm.
Wenn ich in diversen Kommentaren die Pegel hinter dem Filter betrachte, dann scheint meine Messung nicht vollständig falsch zu sein.
Hinzu kommt noch, dass das Filter doch ein wenig zu hoch liegt. Da werde ich mal mit je 15pF versuchen das Filter auf einen günstigeren Bereich zu ziehen.
Das wird aber lediglich 6-8 dB bringen. Vielleicht reicht das ja schon.
Das mit dem koppel-C zum Gatter werde ich aber aich noch mal probieren.

Gruss Dirk

8

Donnerstag, 7. Januar 2010, 10:17

Zitat

Original von DL7VDC

Hinzu kommt noch, dass das Filter doch ein wenig zu hoch liegt. Da werde ich mal mit je 15pF versuchen das Filter auf einen günstigeren Bereich zu ziehen.
Das wird aber lediglich 6-8 dB bringen. Vielleicht reicht das ja schon.
Das mit dem koppel-C zum Gatter werde ich aber aich noch mal probieren.

Gruss Dirk


Das Nachfilter zum DDS ist beidseitig mit 200 Ohm abgeschlossen. Wenn die Filterkurve auf der richtigen Frequenz liegt, dann ist die Dämpfung kein Problem weil der Rest der Schaltung darauf abgestimmt ist. Man braucht gar keinen NWT mit den sich dann ergebenden Anpaßproblemen sondern kann die Durchlasskurve direkt mit dem Hobo selbst ermitteln:

Tastkopf an den Ausgang des Filters oder am Eingang des 7404 anklemmen und dann die DDS Frequenz mit der großen Steprate verändern. Das Maximum der Spannung finden, die angezeigte Frequenz umrechnen auf DDS Frequenz und dann abschätzen oder ausrechnen, wieviel C man zugeben muss um auf die Sollfrequenz zu kommen (ich habe noch kein Filter gesehen, das zu tief lag. Bisher lagen alle zu hoch, die Drosseln scheinen generell zu wenig Induktivität zu haben)
73/2 de Peter, DL2FI
Don´t follow the path. Make one! (Helena Martins, Fotografin, die im Erwachsenenalter ihr Gehör verlor)

9

Samstag, 9. Januar 2010, 14:27

hallo,
mittlerweile habe ich das DDS-Filter in einen günstigeren Bereich gezogen. Je 15pF parallel zu den vorhandenen 82pF des 40m Moduls. Das hat bestimmt mehr als 6dB gebracht. Nun kommt auch ein recht sauberes Signal am Mischer an. Soweit ist jetzt alles im grünen Bereich. Dennoch habe iich 2 Block C's C1 und C4 auf der Mischer Platine (zur Sicherheit) mit Tantal Elko's "verstärkt". Kann ja nicht schaden, dachte ich mir.

Interessieren würde es mich doch, was ich da bei der Messung am DDS-Filter falsch mache. Ich habe immer eine GrundDämpfung von ca. 20dB.
Ist aber nicht mehr so wichtig. Es funktioniert ja jetzt.

Es geht also weiter.

Vielen Dank für die Hilfe.

Gruss Dirk