Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Forum der DL-QRP-AG für QRP und Selbstbau im Amateurfunk. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 27. August 2017, 17:47

FiFi-SDR auf Vista

Hallo

Kann mir jemand bei einem FiFi-SDR Treiberproblem behilflich sein?

Sowohl der Treiber O28-20100927, als auch die Version O28-20130929 führt auf Vista dazu, dass nach Aufruf von Bonito RJ10FiFi V2, HDSDR 2.76 oder SDRSharp ein Bluescreen (Bugcode USB_Driver) auftritt.
Laut Gerätemanager ist der FiFi-Treiber aber korrekt installiert, der FiFi-SDR wird erkannt.
RTL-SDR DVB-T Dongle läuft am selben Rechner ohne Problem.

Vermutlich läuft der FiFi nicht auf Vista. Leider konnte ich nirgends eine wirklich konkrete Info finden (auch nicht hier http://o28.sischa.net/fifisdr/trac/wiki/De%3AWikiStart ).

Frage:
Hat jemand den FiFi-SDR auf Vista zum Laufen gebracht? Wen ja wie?
Oder läuft FiFi definitv nicht auf Vista?

Bitte keine Diskussion über Sinn oder Unsinn das uralte Vista zu nutzen; ebenso über die Nachteile des alten Fifi. Ich möchte einfach für jemanden den FiFi auf einem alten Vista-PC betreiben.

.
73 de Chris, OE3HBW

2

Sonntag, 27. August 2017, 18:08

Moin,

das muss nicht einmal etwas mit dem Treiber zu tun haben. Es kann durchaus sein, dass fehlende Updates oder installierte Sicherheitsupdates die Ursache des Problems sind, d.h. dass dieser Treiber auf anderen Rechnern problemlos laeuft, aber auf diesem nie laufen wird. Ich hatte schon mehrfach den Fall, dass USB Treiber erst mit einem BIOS Update einwandfrei liefen, da lag das Problem nicht einmal am OS. Gleiches gab es auch schon mit Sicherheitsupdates, die zum Patchday einfach mal eben Treiber ausser Funktion gesetzt haben (bitte keine Sprueche wie "Never change a running system", in manchen Bereichen ist man dazu verpflichtet die Systeme aktuell zu halten, weil es einem sonst so gehen kann wie dem VW-Ing.).

Das ist ganz schwer einzukreisen und das es auf anderen PCs funktioniert, muss kein Garant dafuer sein, dass es hier auch geht. Wurde das OS denn regelmaessig aktualisiert oder ist das noch auf dem Stand von vor 10 Jahren?

Falls zur Hand koenntest Du es mit einer zusaetzlichen USB Karte probieren, aber eine Garantie gibt es dafuer auch nicht.

73, Tom
DARC I18 |DL-QRP-AG #1186|G-QRP #14624|FISTS #15933|SKCC #13896|LIDS #88 https://twitter.com/DL7BJ

3

Sonntag, 27. August 2017, 18:35

Hallo Tom!

Danke für Antwort. Das klingt ja nicht wirklich gut.
Das Vista OS wurde übrigens bis zum Auslaufen der MS Unterstützung stets aktualisiert. Bluescreen äußerst selten, die FiFi Sache ist ein Novum.

Ich möchte auch keine Wissenschaft daraus machen. Nur die üblich Anfrage ob jemand zufällig das gleiche Problem hatte und eine Lösung fand...
(in der "Hoffnung" das es tatsächlich ein Treiberproblem ist).

.
73 de Chris, OE3HBW

4

Sonntag, 27. August 2017, 18:56

Moin,

ich sehe erst jetzt, dass der Treiber ja libusb ist, der laeuft eigentlich voellig problemlos. Hast Du mal nach weiteren Infos unabhaengig vom Fifi geschaut? Da koenntest Du fuendig werden, denn libusb ist ja nun nicht gerade unbekannt und wird auch im AVR Umfeld viel verwendet:

https://sourceforge.net/p/libusb-win32/wiki/Home/

Da hast Du auch noch eine Menge anderer Versionen zur Auswahl. Du solltest aber nicht vor 1.2.0 gehen, weil sonst die Signatur des Treibers ein Problem werden koennte.

Vor dem Einsatz eines neuen Treibers solltest Du den alten sauber entfernen, da hilft es auch, im Geraetemanager die ausgeblendeten Geraete anzuzeigen. Insbesondere wenn Systeme aelter sind, sammelt sich da reichlich Muell an und aufraeumen hilft dann schon mal.

http://www.winfaq.de/faq_html/Content/ti…p?h=tip1220.htm

73, Tom
DARC I18 |DL-QRP-AG #1186|G-QRP #14624|FISTS #15933|SKCC #13896|LIDS #88 https://twitter.com/DL7BJ

5

Sonntag, 27. August 2017, 20:42

Hallo Tom,

vielen Dank für den sehr guten Tipp mit der ausgeblendeten Gerätemanageransicht! Erstaunlich was da alles zum Vorschein kommt.

Ja Du hast recht, das FiFi Treiberpaket vom 29.09.2013 enthält:
libusb0.sys
libusb0_x86.dll
libusbK_x86.dll
in der Version 1.2.6.0

Im Gerätemanager habe ich bei libusb-win32 devices
AVR USB Device
FiFi-SDR (20130929)

und bei Audio-,Video- und Gamecontroller
FiFi-SDR AM/FM/SSB-Receiver
FiFi-SDT Soundcard
und eine große Menge anderer...

Das muß ich mir jetzt durch den Kopf gehen lassen, ich befürchte da sind eine Menge Altlasten vorhanden. So habe ich zum Beispiel gesehen, dass da noch eine ZADIG libusb/winusb Instalation vorhanden war...

Verständnisfrage:
Wenn ich zum Beispiel die Zadig Treiber (libusb0, libusbk usw) installiert habe, dann kann ich mir zB für den FiFi die Treiberinstallation sparen oder nicht?

.
73 de Chris, OE3HBW

6

Sonntag, 27. August 2017, 21:01

Hallo Chris,

Verständnisfrage:
Wenn ich zum Beispiel die Zadig Treiber (libusb0, libusbk usw) installiert habe, dann kann ich mir zB für den FiFi die Treiberinstallation sparen oder nicht?

Im Prinzip ja, weil der Treiber schon vorhanden ist. Das merkst Du auch daran, dass keine Meldung nach einer Treibersuche erscheint, wenn Du den FiFi ansteckst. Ausserdem sollte der im Geraetemanager dann auftauchen. Wenn Du mit dem FiFi noch einen USB Port hast, an dem der noch nicht angesteckt war, dann sollte das gleich auffallen.

Wenn aber schon viele Geraete installiert wurden, die alle mit libusb arbeiten und evtl. auch noch manuell Treiber installiert wurden, dann waere ein guter Zeitpunkt, da mal kraeftig aufzuraeumen. Man weiss nicht, was evtl schon mal schiefgelaufen ist oder welche Versionen da vermischt wurden. Das ist immer ein Problem, wenn man nicht mit der Option fuer ausgeblendete Geraete arbeitet, weil dann Treiber liegen bleiben.

Dann solltest Du aber besser vorher ein Backup machen, z.B. mit Clonezilla oder Acronis. Falls in dem Rechner eine Seagate oder Western Digital Platte steckt oder Du eine externe USB Platte von Seagate oder WD hast, dann kannst Du die kostenlose Acronis Version von WD nehmen, um ein Image zu erzeugen: https://support.wdc.com/downloads.aspx?p=119&lang=en

Die funktioniert immer, sobald eine Seagate oder WD Platte im System ist - find ich nett von WD , weil mit True Image kann man ganz schnell ein Image-Backup erzeugen und ein System auch wiederherstellen.

73, Tom
DARC I18 |DL-QRP-AG #1186|G-QRP #14624|FISTS #15933|SKCC #13896|LIDS #88 https://twitter.com/DL7BJ

7

Montag, 28. August 2017, 11:22

Hallo Tom!

Danke für Deine guten Hints - ich denke das Verständnis für das Problem ist jetzt da, der Gerätemanager ist angepasst (wieso eigentlich versteckt MS diese wichtige Funktion derart) und sobald ich Zeit habe wird der Vista-PC durchforstet (natürlich vorher gesichert). Danach erfolgt eine neue Installation der libusb Treiber.

Dennoch wäre es eine Hilfe zu wissen ob jemand den FiFi bereits erfolgreich auf Vista zum Laufen gebracht hat, da die Auswahl einer funktionierenden Treiberversion eine Rolle spielen könnte. Daher Frage ich nochmals nach ob es jemanden gelungen ist den FiFi-SDR auf Vista zum Laufen gebracht zu haben.

.
73 de Chris, OE3HBW

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »chirt« (28. August 2017, 14:29)


Ähnliche Themen

Verwendete Tags

BlueScreen, FiFi-SDR, Treiber, Vista