Sie sind nicht angemeldet.

  • »funker01« ist männlich
  • »funker01« ist der Autor dieses Themas

Beiträge: 79

Hobbys: Selbstbaugeräte, Sprechfunk

  • Nachricht senden

1

Samstag, 1. April 2006, 20:29

Microcontroller tut nicht

Hallo,
nach dem Aufbau der Platine habe ich Probleme, die ich nicht lösen kann.
Der LOD Spannungsregler bringt bei einer Eingangsspannung von 9V lediglich 4,61V am Ausgang. Der Strom beträgt ca. 135mA.
Nach dem Einschalten steht sofort in der Anzeige "HF-M 3.2 DK80H-->".
Beim Drehen des Drehgebers im Uhrzeigersinn erscheinen jeweils kurz eine Zeile schwarzer Quadrate. Beim Drehen gegen den Uhrzeigersinn verändert sich die Anzeige nicht.
Ist dieses Verhalten schon mal jemand aufgefallen? Oder habe nur ich dieses zweifelhafte Glück?
Messungen mit dem Oszi kann ich zur Zeit nicht vornehmen, da ich das Gerät verliehen habe.
Ich hoffe jemand kann mir helfen.
Viele 73 von Hans
Mit einem Draht klappt es nicht -- und ab zwei kann man verwechseln!:D

  • »Alexander DG8KAD« ist männlich

Beiträge: 314

Hobbys: YL Elisabeth DO8ED; Selbstbau; QRP; Funkbetrieb; Conteste; Geschichte

  • Nachricht senden

2

Samstag, 1. April 2006, 21:33

RE: Microcontroller tut nicht

Hallo
Die Meldung HF-M 3.2 DK80H nach dem einschalten ist normal. Wenn du die Grundmaske hast gibt es keine Anzeigen beim drehen gegen den Uhrzeigersinn. Im Uhrzeigersinn sollte die C; L; F1;F2;F3;P;Lux kommen. danach ist Schluß und man kann nur noch gegen den Uhrzeigersinn den Werte bereich verändern.
Schon mal kommt es bei meinem Multi vor, das beim verstellen des Meßbereiches Zeichen wirwar auf dem Display zu sehen ist. Der Fehler trat nach dem wechsel des Porzessors von 1.0 auf 3.2 das erstemal auf.

73

Alexander
Alexander
DG8KAD
DOK G14 Herzogenrath
Ham since 1989
DARC DOK G-14 Herzogenrath
EFA FIRAC
DL-QRP-AG Nummer #2538
Feld Hell Club #4515
AGCW #3819

DIG #6342
QCWA #36458
Ten-Ten 77493

3

Samstag, 1. April 2006, 22:58

RE: Microcontroller tut nicht

Hallo Hans,
Wie schon kommentiert "links herum bleibt der Text "...DK80H..."
rechts herum kommen die Funktionen C, L, F1...E.
Aber 135mA sind zu viel, die Schaltung braucht zwischen 70-80 mA (irgend eine Lötbrücke ??,oder hast Du die LCD Beleuchtung eingeschaltet ? ) und deshalb scheinen mir auch die 4.61 V zu niedrig. Ich hatte allerdings auch schon einmal einen Spannungsregler der nicht 5.0V brachte (also ggf einmal tauschen und checken wie es dann aussieht)
Noch eine Idee: alle Chips sind richtig orientiert eingebaut ??
Akribisch mit der Dokumentation vergleichen !!!! 8o
72, 73 Eric

  • »funker01« ist männlich
  • »funker01« ist der Autor dieses Themas

Beiträge: 79

Hobbys: Selbstbaugeräte, Sprechfunk

  • Nachricht senden

4

Sonntag, 2. April 2006, 09:11

RE: Microcontroller tut nicht

Hallo,
schönen Dank für die schnellen Antworten. Es sind keine Lötbrücken, wie auch immer , vorhanden. Mehrfach geprüft. IC´s sind alle in der richtigen Richtung eingesteckt. Die LED Beleuchtung ist nicht angeschlossen.
Laut meiner Beschreibung soll nach dem Einschalten für ca. 2-3 sek die Meldung "SET UP" kommen, dann erst "HF-M 3.2...". Die setup Meldung kommt bei mir überhaupt nicht. Auch nach mehreren Minuten kann man mittels des Drehgebers keine Einstellung verändern. ?(
Ohne Spannungsregler, mit fester 5V zieht die Schaltung ca. 160 mA. Der Regler geht scheinbar zu früh in die Strombegrenzung.
Weitergehende Messungen kann ich erst im laufe der Woche vornehmen, wenn ich meinen Oszi zurück habe. X( ?(
Viele 73 von Hans
Mit einem Draht klappt es nicht -- und ab zwei kann man verwechseln!:D

  • »Alexander DG8KAD« ist männlich

Beiträge: 314

Hobbys: YL Elisabeth DO8ED; Selbstbau; QRP; Funkbetrieb; Conteste; Geschichte

  • Nachricht senden

5

Sonntag, 2. April 2006, 11:03

RE: Microcontroller tut nicht

Hallo

Zitat

Laut meiner Beschreibung soll nach dem Einschalten für ca. 2-3 sek die Meldung "SET UP" kommen, dann erst "HF-M 3.2...". Die setup
Bei meinem Multi kommt die Meldung "SET up" nicht mehr seit dem ich auf Version 3.2 umgestellt habe.. Er meldet sich mit HF-M 3.2 ... sofort an.

Hast du den Widerstand 5,6 Kohm Widerstand auf der Unterseite eingelötet?


Zitat

Mit dem Atmega kann die Referenzspannung für den Analog-Digital-
Wandler aus einer genauen und stabilen internen Spannung gewonnen
werden. Deswegen entfallen die Widerstände R17 und R18. Der Kondensator
C24 bleibt für die Stabilisierung der internen Referenzspannung im Gerät.
Mit der neuen Software ändert sich geringfügig die Ansteuerung des LCD.
Dazu muss das Signal vom Controller Pin 16 (PB2) zum LCD Pin 5 (RW) mit
einem Widerstand von 560Ohm an Masse gelegt werden.
[ ] 560 Ohm wie im Foto auf die Platine löten

72Alexander
Alexander
DG8KAD
DOK G14 Herzogenrath
Ham since 1989
DARC DOK G-14 Herzogenrath
EFA FIRAC
DL-QRP-AG Nummer #2538
Feld Hell Club #4515
AGCW #3819

DIG #6342
QCWA #36458
Ten-Ten 77493

6

Sonntag, 2. April 2006, 13:30

RE: Microcontroller tut nicht

Hallo,

Es gibt eine neuere Bauanleitung mit Stand 17.Okt.2005 aus dem die Zitate stammen, mit íhr kommt auch eine neue Kalibrier SW "gbo 504".

1) die sofortige Meldung HF-M 3.2 .... ist auch bei mir "normal"

2) hier einige Ströme, wenn man je ein IC herausnimmt, dann wieder einsteckt und dann das nächste IC herauszieht (alles in Stellung C , mit einem Gesamtstrom bei mir von 64.5mA) :
-- ohne Max232 63mA -> 1.5mA für den Max
-- ohne U893 46mA -> 18.5mA für den U893
-- ohne 8307 57mA -> 7.5mA für den AD8307
-- ohne LM311 59.5mA -> 5.0mA für den LM311
-- ohne 4520 60.0mA -> 4.5mA für den HC4520
-- ohne mega 58.0mA -> 6.5mA für den ATmega
-- ohne 151 54.5mA -> 10mA für den HC151
Damit müsste einzukreisen sein, wer der Stromfresser ist oder wo bei den verbleibenden Komponenten (Display ca 1mA, Vorverstärker) der Fehler liegt.
73, Eric

  • »funker01« ist männlich
  • »funker01« ist der Autor dieses Themas

Beiträge: 79

Hobbys: Selbstbaugeräte, Sprechfunk

  • Nachricht senden

7

Montag, 3. April 2006, 18:28

RE: Microcontroller tut nicht

Hallo,
nochmals vielen Dank für die Tipps. Asche auf mein Haupt. Der Elko C16 war verdreht eingelötet :O. Vom Prinzip her funktionieren alle Einstellmöglichkeiten. Jetzt kommt der Abgleich! Mal sehen welche Überraschungen noch auf mich warten?!
Werde später berichten.
Viele 73 von Hans
Mit einem Draht klappt es nicht -- und ab zwei kann man verwechseln!:D